summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-15 18:06:38 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-16 13:33:40 +0100
commit1802203acabc1bab7f11697437e6a65f3553bb00 (patch)
tree8b10927b6e2544ad92079481eb67b789efdccda0
parentdev-python/pypy3-bin: Fix mtimes between generated and source files (diff)
downloadgentoo-1802203a.tar.gz
gentoo-1802203a.tar.bz2
gentoo-1802203a.zip
sys-devel/lld: Remove obsolete PTHREAD_LIB hack
Upstream now correctly propagates pthread libraries via LLVM_PTHREAD_LIB in LLVMConfig.cmake, so the hack is no longer necessary.
-rw-r--r--sys-devel/lld/lld-5.0.0.ebuild2
-rw-r--r--sys-devel/lld/lld-5.0.9999.ebuild2
-rw-r--r--sys-devel/lld/lld-9999.ebuild2
3 files changed, 0 insertions, 6 deletions
diff --git a/sys-devel/lld/lld-5.0.0.ebuild b/sys-devel/lld/lld-5.0.0.ebuild
index dabb7f02f743..87a3c859909b 100644
--- a/sys-devel/lld/lld-5.0.0.ebuild
+++ b/sys-devel/lld/lld-5.0.0.ebuild
@@ -51,8 +51,6 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
- # TODO: fix detecting pthread upstream in stand-alone build
- -DPTHREAD_LIB='-lpthread'
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=ON
diff --git a/sys-devel/lld/lld-5.0.9999.ebuild b/sys-devel/lld/lld-5.0.9999.ebuild
index 6c2601f5d423..c47d7243527e 100644
--- a/sys-devel/lld/lld-5.0.9999.ebuild
+++ b/sys-devel/lld/lld-5.0.9999.ebuild
@@ -58,8 +58,6 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
- # TODO: fix detecting pthread upstream in stand-alone build
- -DPTHREAD_LIB='-lpthread'
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=ON
diff --git a/sys-devel/lld/lld-9999.ebuild b/sys-devel/lld/lld-9999.ebuild
index a8e3f4f39dc9..a7b5d23282c8 100644
--- a/sys-devel/lld/lld-9999.ebuild
+++ b/sys-devel/lld/lld-9999.ebuild
@@ -57,8 +57,6 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
- # TODO: fix detecting pthread upstream in stand-alone build
- -DPTHREAD_LIB='-lpthread'
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=ON