summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-29 13:54:43 +0100
committerSam James <sam@gentoo.org>2021-10-29 14:02:37 +0100
commit180f62b77c04cfe336aa19952cbc6af5e37329cb (patch)
tree814b38ba8b637de6af350a8a2fad8fb1c0e3743a
parentapp-editors/vim: add 8.2.3567 (diff)
downloadgentoo-180f62b7.tar.gz
gentoo-180f62b7.tar.bz2
gentoo-180f62b7.zip
app-editors/vim-core: slightly modernise ebuild
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim-core/vim-core-8.2.3428.ebuild16
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild16
2 files changed, 18 insertions, 14 deletions
diff --git a/app-editors/vim-core/vim-core-8.2.3428.ebuild b/app-editors/vim-core/vim-core-8.2.3428.ebuild
index 6f4dbf0832ac..df9cd899e381 100644
--- a/app-editors/vim-core/vim-core-8.2.3428.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.3428.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+# Please bump with app-editors/vim and app-editors/gvim
+
VIM_VERSION="8.2"
inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop xdg-utils
@@ -14,23 +17,22 @@ else
https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
+S="${WORKDIR}"/vim-${PV}
DESCRIPTION="vim and gvim shared files"
HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
-SLOT="0"
LICENSE="vim"
+SLOT="0"
IUSE="nls acl minimal"
-DEPEND="sys-devel/autoconf"
-# avoid icon file collision bug #673880
+BDEPEND="sys-devel/autoconf"
+# Avoid icon file collision, bug #673880
RDEPEND="!!<app-editors/gvim-8.1.0648"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
-S=${WORKDIR}/vim-${PV}
-
pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
+ # people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
export LC_COLLATE="C"
@@ -50,7 +52,7 @@ src_prepare() {
-e '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \
"${S}"/runtime/tools/mve.awk || die "sed failed"
- # See #77841. We remove this file after the tarball extraction.
+ # See bug #77841. We remove this file after the tarball extraction.
rm -v "${S}"/runtime/tools/vimspell.sh || die "rm failed"
# Read vimrc and gvimrc from /etc/vim
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index f141342833a8..1dfe65d75bdb 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+# Please bump with app-editors/vim and app-editors/gvim
+
VIM_VERSION="8.2"
inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop xdg-utils
@@ -14,23 +17,22 @@ else
https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
+S="${WORKDIR}"/vim-${PV}
DESCRIPTION="vim and gvim shared files"
HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
-SLOT="0"
LICENSE="vim"
+SLOT="0"
IUSE="nls acl minimal"
-DEPEND="sys-devel/autoconf"
-# avoid icon file collision bug #673880
+BDEPEND="sys-devel/autoconf"
+# Avoid icon file collision, bug #673880
RDEPEND="!!<app-editors/gvim-8.1.0648"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
-S=${WORKDIR}/vim-${PV}
-
pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
+ # people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
export LC_COLLATE="C"
@@ -50,7 +52,7 @@ src_prepare() {
-e '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \
"${S}"/runtime/tools/mve.awk || die "sed failed"
- # See #77841. We remove this file after the tarball extraction.
+ # See bug #77841. We remove this file after the tarball extraction.
rm -v "${S}"/runtime/tools/vimspell.sh || die "rm failed"
# Read vimrc and gvimrc from /etc/vim