summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-11 22:31:38 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-11 22:31:38 +0200
commit184e42f322411aa7d7e4b98667a28a0d6bc6a90a (patch)
tree5a362cc7a0e8144123c77d93cead702aeca580b4
parentapp-misc/datovka: fix homepage, src_uri (diff)
downloadgentoo-184e42f3.tar.gz
gentoo-184e42f3.tar.bz2
gentoo-184e42f3.zip
app-crypt/xor-analyze: EAPI 6 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild b/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
new file mode 100644
index 000000000000..379db39defbc
--- /dev/null
+++ b/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="program for cryptanalyzing xor 'encryption' with variable key length"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=xor-analyze"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ rm -f Makefile || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" xor-analyze xor-enc
+}
+
+src_install() {
+ dobin xor-analyze xor-enc
+ dosym xor-enc /usr/bin/xor-dec
+ dodoc README TODO
+}