summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-15 09:08:10 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-15 10:09:19 +0200
commit1850c352c5f38c892e212aa4e4c6ccc6e5022dd0 (patch)
treec5373b663d3183a6ab32a160be39141f7116deb5
parentdev-ruby/tidy-ext: enable ruby30, ruby31 (diff)
downloadgentoo-1850c352c5f38c892e212aa4e4c6ccc6e5022dd0.tar.gz
gentoo-1850c352c5f38c892e212aa4e4c6ccc6e5022dd0.tar.bz2
gentoo-1850c352c5f38c892e212aa4e4c6ccc6e5022dd0.zip
dev-ruby/mash: enable ruby30, ruby31
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/mash/mash-0.1.1-r3.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-ruby/mash/mash-0.1.1-r3.ebuild b/dev-ruby/mash/mash-0.1.1-r3.ebuild
index 0f82122dc1c7..ff5e1df922ee 100644
--- a/dev-ruby/mash/mash-0.1.1-r3.ebuild
+++ b/dev-ruby/mash/mash-0.1.1-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
@@ -18,3 +18,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/be_true/be true/' -e 's/be_false/be false/' spec/mash_spec.rb || die
+}