summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-06-12 15:28:00 +0200
committerArsen Arsenović <arsen@gentoo.org>2023-06-12 18:13:22 +0200
commit188326e40071b690e73532f1eba226fdb53f7543 (patch)
treeffb3c4c829272ce75d47dc7e50ff5bcae3aab0e6
parentprofiles/features/wd40: Mask dev-python/rpds-py and revdeps (diff)
downloadgentoo-188326e40071b690e73532f1eba226fdb53f7543.tar.gz
gentoo-188326e40071b690e73532f1eba226fdb53f7543.tar.bz2
gentoo-188326e40071b690e73532f1eba226fdb53f7543.zip
app-emacs/cape: new package, add 0.15
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
-rw-r--r--app-emacs/cape/Manifest1
-rw-r--r--app-emacs/cape/cape-0.15.ebuild39
-rw-r--r--app-emacs/cape/cape-9999.ebuild39
-rw-r--r--app-emacs/cape/files/50cape-gentoo.el3
-rw-r--r--app-emacs/cape/metadata.xml15
5 files changed, 97 insertions, 0 deletions
diff --git a/app-emacs/cape/Manifest b/app-emacs/cape/Manifest
new file mode 100644
index 000000000000..b719c2277d70
--- /dev/null
+++ b/app-emacs/cape/Manifest
@@ -0,0 +1 @@
+DIST cape-0.15.tar.xz 25848 BLAKE2B 44d72cd8de7597dad6f92c225995a5e1c02f42daf7a839c98e2b3d3ec0ff66dba5da64fc87d64b4913c5f9598cb00e3b46e22eaf98f65a759f4c04c9b373a3b2 SHA512 a2ea009f1f28868ac7c58f23e9212568545434588d89a2f15e5b1a0f4dba09a27a5620a9b9ac79cb88da3a9e83174f13a6122425581dd0aa43e25d12f1766396
diff --git a/app-emacs/cape/cape-0.15.ebuild b/app-emacs/cape/cape-0.15.ebuild
new file mode 100644
index 000000000000..f7f6e19f558b
--- /dev/null
+++ b/app-emacs/cape/cape-0.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/cape.git"
+else
+ # Recompressed from ELPA.
+ SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+ KEYWORDS="~amd64"
+ ELISP_REMOVE="${PN}-pkg.el"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ if [[ ${PV} != 9999 ]]; then
+ doinfo cape.info
+ fi
+}
diff --git a/app-emacs/cape/cape-9999.ebuild b/app-emacs/cape/cape-9999.ebuild
new file mode 100644
index 000000000000..f7f6e19f558b
--- /dev/null
+++ b/app-emacs/cape/cape-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/cape.git"
+else
+ # Recompressed from ELPA.
+ SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+ KEYWORDS="~amd64"
+ ELISP_REMOVE="${PN}-pkg.el"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ if [[ ${PV} != 9999 ]]; then
+ doinfo cape.info
+ fi
+}
diff --git a/app-emacs/cape/files/50cape-gentoo.el b/app-emacs/cape/files/50cape-gentoo.el
new file mode 100644
index 000000000000..84d436d35cd5
--- /dev/null
+++ b/app-emacs/cape/files/50cape-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/cape site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/cape-autoloads.el" nil t)
diff --git a/app-emacs/cape/metadata.xml b/app-emacs/cape/metadata.xml
new file mode 100644
index 000000000000..704398b0a728
--- /dev/null
+++ b/app-emacs/cape/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">minad/cape</remote-id>
+ </upstream>
+</pkgmetadata>