summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-16 04:59:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-16 04:59:09 +0200
commit1890ccdd64e096c846d18875e880b6de1835f43a (patch)
tree9d416ecb83ee74ccc62976b867812617ba54aaee
parentdev-python/reedsolo: Bump to 2.1.1_beta1 (diff)
downloadgentoo-1890ccdd64e096c846d18875e880b6de1835f43a.tar.gz
gentoo-1890ccdd64e096c846d18875e880b6de1835f43a.tar.bz2
gentoo-1890ccdd64e096c846d18875e880b6de1835f43a.zip
dev-python/dnspython: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-2.4.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 6aa1cf078ca9..f615512fea32 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1 +1,2 @@
DIST dnspython-2.3.0.gh.tar.gz 339222 BLAKE2B 1e1bfd1d716f5afce1ccc2e0f1fbb8e575e91619bc32f2c5067f6da4e01ea927dd0a1ed4c35e6c88d34de320befd833c9c17d060ea71918775c1f5f0121b61a8 SHA512 0bb4b41262a1d97b724e48b4dfb70f1fb544c18824e7d2bc2dcb8ef6c943c6c827ce753ae4ccb2ab37e95c8f5ff5d2f4853f238509f21e6299a445760c41e10e
+DIST dnspython-2.4.0.gh.tar.gz 356155 BLAKE2B d77ac611a45bb6f19903752af480e03d25655e0c814768c67b9a605c7a41a8c17efa976a4ff55fcc7de811113415addb094f8edefb5ebaa29b25d5a5865ea9ab SHA512 61becb66d049f9a503a4e60195183cd7b2f6dfb67d28aac85e39d26d30abd1eb97b52f368796438d90a4ff9acb441d1e487d5699484c77ec58e3914885d66aca
diff --git a/dev-python/dnspython/dnspython-2.4.0.ebuild b/dev-python/dnspython/dnspython-2.4.0.ebuild
new file mode 100644
index 000000000000..00c4ada172dc
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="dnssec examples"
+
+RDEPEND="
+ dnssec? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ <dev-python/idna-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -s
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}