summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2020-09-26 13:08:15 +0200
committerBenda Xu <heroxbd@gentoo.org>2020-11-09 14:52:49 +0800
commit189e49f7a6ebd821e81ff48611d90c1b935162f6 (patch)
tree14cfd60462b3db62e9e2b868c637928286c31a8e
parentdev-ruby/ruby-prof: add 1.4.2 (diff)
downloadgentoo-189e49f7a6ebd821e81ff48611d90c1b935162f6.tar.gz
gentoo-189e49f7a6ebd821e81ff48611d90c1b935162f6.tar.bz2
gentoo-189e49f7a6ebd821e81ff48611d90c1b935162f6.zip
sci-astronomy/wcslib: verbump to 7.3
Closes: https://github.com/gentoo/gentoo/pull/17674 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sci-astronomy/wcslib/Manifest1
-rw-r--r--sci-astronomy/wcslib/metadata.xml4
-rw-r--r--sci-astronomy/wcslib/wcslib-7.3.ebuild66
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
index 15dd94837999..1b39294abf06 100644
--- a/sci-astronomy/wcslib/Manifest
+++ b/sci-astronomy/wcslib/Manifest
@@ -1 +1,2 @@
DIST wcslib-5.16.tar.bz2 2222111 BLAKE2B e11da145db6366804321cf415bdac621a930418f09d788c8b94413980710bb43357129a830462339127398082700a9f44f56dc0b8c96ef923d41ea0174dfd07f SHA512 bf7ab586995bdade8b96c77dee891c7d7ab6de82a7e2f94a09d89643e93658063f832efdb66e0bba11ad114b6e0ca555cba9308a84f0f22fb833e3a6303cefe6
+DIST wcslib-7.3.tar.bz2 2435669 BLAKE2B c0f641b4c2fdd9d332816195f399eb2ab3c5aa585f08c4857af77bd5ed4074e653663f7cbddc6d7678cd85bed2c0bd95719cd83a5138d21ad24841396d4c11b9 SHA512 8c98c4b575056e2d966b77a4bc951256d02ecee3a11847e140fd38d93afd0f76b3e906d590c952dc9fc58ceeb1ba062b19d8e1e676ee0032f5b7ed13a9dfa892
diff --git a/sci-astronomy/wcslib/metadata.xml b/sci-astronomy/wcslib/metadata.xml
index f74e78465e2d..809842b35b0f 100644
--- a/sci-astronomy/wcslib/metadata.xml
+++ b/sci-astronomy/wcslib/metadata.xml
@@ -5,6 +5,10 @@
<email>sci-astronomy@gentoo.org</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
+ <maintainer type="person">
+ <email>davidroman96@gmail.com</email>
+ <name>David Roman</name>
+ </maintainer>
<longdescription lang="en">
WCSLIB is a C library, supplied with a full set of Fortran wrappers,
that implements the "World Coordinate System" (WCS) convention in FITS
diff --git a/sci-astronomy/wcslib/wcslib-7.3.ebuild b/sci-astronomy/wcslib/wcslib-7.3.ebuild
new file mode 100644
index 000000000000..1a490f77abdc
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-7.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/7"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs +tools"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable fortran)
+ $(use_enable tools utils)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf ${myconf[@]}
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_test() {
+ emake check
+}
+
+src_install () {
+ default
+ # static libs share the same symbols as shared (i.e. compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}