summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-29 21:45:16 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-29 21:59:55 -0400
commit18a27f0913413b84af17431c7e7f27dde3456144 (patch)
tree127067229a8e59d6c0cf2f0849e78d068509dfeb
parentgames-engines/devilutionx: add 1.4.0 (diff)
downloadgentoo-18a27f09.tar.gz
gentoo-18a27f09.tar.bz2
gentoo-18a27f09.zip
games-engines/devilutionx: drop broken live ebuild
This needs additional tools to generate assets and fetching/moving sources if not from a release tarball (formerly was kept in git, but not anymore) and would rather not maintain that. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-engines/devilutionx/devilutionx-9999.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/games-engines/devilutionx/devilutionx-9999.ebuild b/games-engines/devilutionx/devilutionx-9999.ebuild
deleted file mode 100644
index 2a2abba3eba0..000000000000
--- a/games-engines/devilutionx/devilutionx-9999.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Sometimes build with ninja fails.
-# Please check occasionally if we can revert back to ninja.
-# Latest known issue:
-#
-#CMAKE_MAKEFILE_GENERATOR="emake"
-
-inherit cmake
-
-DESCRIPTION="Diablo engine for modern operating systems"
-HOMEPAGE="https://github.com/diasurgical/devilutionX"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/diasurgical/devilutionX.git"
-else
- SRC_URI="https://github.com/diasurgical/devilutionX/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/devilutionX-${PV}"
-fi
-
-LICENSE="public-domain"
-SLOT="0"
-
-IUSE="debug lto"
-
-RDEPEND="
- dev-libs/libsodium:=
- media-fonts/sil-charis
- media-libs/libsdl2[haptic]
- media-libs/sdl2-mixer
- media-libs/sdl2-ttf
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.2.0_pre-no_bundled_font.patch" #704508
- "${FILESDIR}/${PN}-1.2.1-disable-ccache.patch" #813768
-)
-
-DOCS=( docs/CHANGELOG.md )
-
-src_configure() {
- local mycmakeargs=(
- -DASAN="OFF"
- -DDEBUG="$(usex debug)"
- -DDISABLE_LTO="$(usex !lto)"
- # Must be off to force dynamic linking.
- # See bug #791031
- -DDIST="OFF"
- -DUBSAN="OFF"
- )
-
- if [[ "${PV}" != 9999 ]] ; then
- mycmakeargs+=( -DVERSION_NUM="${PV}" )
- fi
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- einfo "In order to play the game you need to install the file"
- einfo " diabdat.mpq"
- einfo "from the original game CD into the following directory:"
- einfo " \${HOME}/.local/share/diasurgical/devilution/"
-}