summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-20 03:54:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-20 03:54:26 +0200
commit18b7c32e60c0b0a065658fc6932eb96a5083d152 (patch)
tree807cf7e9f19d05c6e3e1feaa3bf520027117e0f9
parentapp-admin/rsyslog: bump to 8.2304.0 (diff)
downloadgentoo-18b7c32e60c0b0a065658fc6932eb96a5083d152.tar.gz
gentoo-18b7c32e60c0b0a065658fc6932eb96a5083d152.tar.bz2
gentoo-18b7c32e60c0b0a065658fc6932eb96a5083d152.zip
dev-python/botocore: Bump to 1.29.116
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.116.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d5eb677f84a1..6fa721da61cc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.29.112.gh.tar.gz 11380151 BLAKE2B 0392abe4e6be29a9e3eae1e693d7cc
DIST botocore-1.29.113.gh.tar.gz 11386284 BLAKE2B a3611f356f25080f00f675b20a8b49952bcf1e464b9a114bf37392ebdf4573ac1e9eb6373c61dbf87f8101e055f4f6600f7825f45b00c5723c1528d74865dd6c SHA512 8a16fdde7099ae75a3587ee0c0108c12a6c5c27dbbbfc2d98eb3ccd4c66b45f0389a722f1b10ac3f3cc69ea7ba9135cc0604e35126cc2691a26f4a6173d5258a
DIST botocore-1.29.114.gh.tar.gz 11388772 BLAKE2B 6c9ce892cccf2f85ba4bcd49b31309528016313bb699efbca3b00d3cf3797de5e1b35bd71a3b5bd6d471e9c411ad7750ebd25c03571aa18c34cd42bc2f47bc19 SHA512 6633a2aaf2865a89976ba4097fa64cee4167a9144d4eadc7d9be711e65735bab08d2c03c18ae52c4901fea47265301cb95c91306b261fb48b4119bec66cde376
DIST botocore-1.29.115.gh.tar.gz 11394187 BLAKE2B 621be4a22b7f06d520bcd630ed6e1a8721d11d5c7822f56f54907177d0773b69247b627a42cfbb1b8e053f54ea16f7238acc0d485379c1e071b6e917ea625596 SHA512 525d8f219cad541c4cc125c2d5eeb7595fba6192bda23e7bcc02a65e4ec413756ae3d8ab5bcb3185b5c837bc7214c22146e52716ff010cc396bc8d32cd98b956
+DIST botocore-1.29.116.gh.tar.gz 11399292 BLAKE2B 47a53b2612804911465f6f56a78f79e389ac7bd2e29e3f45c60f25ec1e700df8956dac034d058974bb453623d5ed5edc416d07b45427cb1ef3c584b5ec4b97f3 SHA512 81636c104a0c4b4f04ebeb066171be206929d5eaf2c40e6f383e701a9dc917f84d4b2f9ef2d7a26b278960af7561316d289be4150eede9a56be20dbf606aa57c
diff --git a/dev-python/botocore/botocore-1.29.116.ebuild b/dev-python/botocore/botocore-1.29.116.ebuild
new file mode 100644
index 000000000000..491b6bbc21f2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.116.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}