summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-10-04 21:07:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-10-04 21:09:22 -0500
commit19023be5cea10aefa96c55ec826e035075cf4e35 (patch)
treee810578a11f81eff78f7015a04b1833b29e4b893
parentapp-crypt/acme: add 2.7.0 (diff)
downloadgentoo-19023be5cea10aefa96c55ec826e035075cf4e35.tar.gz
gentoo-19023be5cea10aefa96c55ec826e035075cf4e35.tar.bz2
gentoo-19023be5cea10aefa96c55ec826e035075cf4e35.zip
app-crypt/certbot: add 2.7.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-2.7.0.ebuild62
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild2
3 files changed, 64 insertions, 1 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 6bc3eac1503d..41b4e913854e 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1 +1,2 @@
DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
+DIST certbot-2.7.0.gh.tar.gz 1336481 BLAKE2B 224f26819ee55b99a26540e7f56a8466c806d08149cce511d28d77ce9f5fb8073ec65e6cfa3e0c168ca84ddcbf85478ff335b84feaadee66db6c5a811be202be SHA512 1e1defcd143f804a36b50e3104d239bf20873545474ceb654269a5879e15cfbb76a18bd569f5e6e12de1036779e72c74d9896707daabc314fc5d67acc1c5180d
diff --git a/app-crypt/certbot/certbot-2.7.0.ebuild b/app-crypt/certbot/certbot-2.7.0.ebuild
new file mode 100644
index 000000000000..28d628bba116
--- /dev/null
+++ b/app-crypt/certbot/certbot-2.7.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+S="${WORKDIR}/${P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 31a618c23d65..28d628bba116 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -47,7 +47,7 @@ BDEPEND="
# See certbot/setup.py for acme >= dep
RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- >=dev-python/ConfigArgParse-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
>=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
>=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
>=dev-python/distro-1.0.1[${PYTHON_USEDEP}]