summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-28 19:27:03 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-28 19:27:12 +0100
commit190d6e9fff6f51a1d7e7a818f21c5e323a0714bb (patch)
treeed08f88a1bcb3d6bad5479ee478f9784e32b8a45
parentprofiles/package.mask dev-java/* last-rites (diff)
downloadgentoo-190d6e9f.tar.gz
gentoo-190d6e9f.tar.bz2
gentoo-190d6e9f.zip
dev-lang/fennel: new package; add version 0.9.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/fennel/Manifest1
-rw-r--r--dev-lang/fennel/fennel-0.9.1.ebuild32
-rw-r--r--dev-lang/fennel/metadata.xml29
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-lang/fennel/Manifest b/dev-lang/fennel/Manifest
new file mode 100644
index 000000000000..fc8d0dcd8dd1
--- /dev/null
+++ b/dev-lang/fennel/Manifest
@@ -0,0 +1 @@
+DIST fennel-0.9.1.tar.gz 203441 BLAKE2B 74f461b3e7a24cdae0c8dde590814cb9753a12ab62e797746cc8753d178007a09084037e443d8309fa11ff309a5c6bf6c2e369942ef357aa0402883cef278542 SHA512 87e7ffbef0b49499a93255f50e77f53b9be4faa6d4609d8d65e3a64470bbf07b49a55e7dd547fda4b0e5fe0f4f1e6ece18282cc89955a57ed0a50be8dc01261c
diff --git a/dev-lang/fennel/fennel-0.9.1.ebuild b/dev-lang/fennel/fennel-0.9.1.ebuild
new file mode 100644
index 000000000000..856dc1383b01
--- /dev/null
+++ b/dev-lang/fennel/fennel-0.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1,3,4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="Lisp-like language that compiles to Lua"
+HOMEPAGE="https://fennel-lang.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~technomancy/fennel"
+else
+ SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake LUA_LIB_DIR="${ED}/$(lua_get_lmod_dir)" PREFIX="${ED}/usr" install
+ doman ${PN}.1
+ dodoc *.md
+}
diff --git a/dev-lang/fennel/metadata.xml b/dev-lang/fennel/metadata.xml
new file mode 100644
index 000000000000..7be4ec2ae425
--- /dev/null
+++ b/dev-lang/fennel/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fennel is a lisp that compiles to Lua. It aims to be easy to use,
+ expressive, and has almost zero overhead compared to handwritten Lua.
+
+ - Full Lua compatibility - You can use any function or library from Lua.
+ - Zero overhead - Compiled code should be just as or more efficient
+ than hand-written Lua.
+ - Compile-time macros - Ship compiled code with no runtime dependency
+ on Fennel.
+ - Embeddable - Fennel is a one-file library as well as an executable.
+ Embed it in other programs to support runtime extensibility and
+ interactive development.
+
+ At https://fennel-lang.org there's a live in-browser REPL you can use
+ without installing anything.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bakpakin/Fennel/issues</bugs-to>
+ <remote-id type="github">bakpakin/Fennel</remote-id>
+ </upstream>
+</pkgmetadata>