summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 18:25:20 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:51 +0200
commit1911668c1860f18a6c20c6c72b69ede309a91500 (patch)
tree6a793617b4858a6d7bc67e83c18f0bdaf4eba6b9
parentapp-vim/vim-commentary: EAPI8 bump (diff)
downloadgentoo-1911668c1860f18a6c20c6c72b69ede309a91500.tar.gz
gentoo-1911668c1860f18a6c20c6c72b69ede309a91500.tar.bz2
gentoo-1911668c1860f18a6c20c6c72b69ede309a91500.zip
app-vim/vim-flake8: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-vim/vim-flake8/vim-flake8-1.6-r1.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/app-vim/vim-flake8/vim-flake8-1.6-r1.ebuild b/app-vim/vim-flake8/vim-flake8-1.6-r1.ebuild
new file mode 100644
index 000000000000..a0e086fe68fb
--- /dev/null
+++ b/app-vim/vim-flake8/vim-flake8-1.6-r1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: runs the currently open file through flake8"
+HOMEPAGE="https://github.com/nvie/vim-flake8"
+SRC_URI="https://github.com/nvie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/flake8"