summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-04-07 10:30:06 +0000
committerMatthew Smith <matthew@gentoo.org>2024-04-07 10:40:02 +0000
commit19144666bfe9ab3895677c8801733a25909cef06 (patch)
tree9332362bb829f53639361b67d219ff3d726fd389
parentmedia-gfx/renderdoc: add 1.32 (diff)
downloadgentoo-19144666bfe9ab3895677c8801733a25909cef06.tar.gz
gentoo-19144666bfe9ab3895677c8801733a25909cef06.tar.bz2
gentoo-19144666bfe9ab3895677c8801733a25909cef06.zip
app-emacs/cmake-mode: add 3.29.1
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--app-emacs/cmake-mode/Manifest1
-rw-r--r--app-emacs/cmake-mode/cmake-mode-3.29.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/cmake-mode/Manifest b/app-emacs/cmake-mode/Manifest
index edeab127d14a..277c0059e977 100644
--- a/app-emacs/cmake-mode/Manifest
+++ b/app-emacs/cmake-mode/Manifest
@@ -1,2 +1,3 @@
DIST cmake-3.28.3.tar.gz 11067653 BLAKE2B a329c7cd80e8e74d11ec2a8b377857b1ae8c4c50a792f982803fcc6a00f531ecb7ac2dd7ccad34968b3e3efc14933085b51425974fc5ee29b6c49c2da5ceeaf4 SHA512 66e923925b764e1fe3d150c69dab3e0abd9e0c90d8e30cab63c3a1f70c3e37df0a5e3ff12b378eeae3bdc6608495f41399e6f81602e26b513b19fa19ff6c48fc
DIST cmake-3.29.0.tar.gz 11244341 BLAKE2B 76244cfc6222ce23dbddc9bb3aa51d98d00826d6fa19d86b836f63977c56f0cae11cd592efa1c727e8872fea1e6365a3b67a37e80e588fbf4189f7ec07c2f6e1 SHA512 abcca7a4db221d98864b77220445f0b70f87149626d3162ed49636862b87514b2640318438c0c711bfaafa1aba4d049b55f98e6ac28c44545543986c35fbd062
+DIST cmake-3.29.1.tar.gz 11246071 BLAKE2B ec20bccb354a7097d8f2b1bd3486c162a93085671e10e4839c043b2452f597e4b8789dae887c88677d945ea7dcc71b8b0f30116103aac875270f52468bfc9bc0 SHA512 3665ddb356bf973f75c9f2601f7210f7ff58c77c39926a43af8640979777a796d441df43fda5d2632548f7d15e4553829680c76f3d9376f9e763fe7bba16f3d7
diff --git a/app-emacs/cmake-mode/cmake-mode-3.29.1.ebuild b/app-emacs/cmake-mode/cmake-mode-3.29.1.ebuild
new file mode 100644
index 000000000000..e6ca0450dffd
--- /dev/null
+++ b/app-emacs/cmake-mode/cmake-mode-3.29.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_P="${P/-mode}"
+MY_P="${MY_P/_/-}"
+
+DESCRIPTION="GNU Emacs mode for handling CMake build files"
+HOMEPAGE="https://cmake.org/"
+SRC_URI="https://cmake.org/files/v$(ver_cut 1-2)/${MY_P}.tar.gz"
+S="${WORKDIR}/${P/-mode}/Auxiliary"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !dev-build/cmake[emacs(-)]
+"
+
+DOCS=()
+SITEFILE="50${PN/-mode}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}