summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-12 10:50:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-12 17:26:40 +0200
commit1923e0c3dbe18c667361c3ab6e5a188a02f8c006 (patch)
tree44dd4d509f8448765c21a59ff740e3dc26a1fa6c
parentsys-apps/kexec-tools: Removed old. (diff)
downloadgentoo-1923e0c3dbe18c667361c3ab6e5a188a02f8c006.tar.gz
gentoo-1923e0c3dbe18c667361c3ab6e5a188a02f8c006.tar.bz2
gentoo-1923e0c3dbe18c667361c3ab6e5a188a02f8c006.zip
sys-apps/kexec-tools: Bump to version 2.0.20_rc1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/kexec-tools/Manifest1
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.20_rc1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/kexec-tools/Manifest b/sys-apps/kexec-tools/Manifest
index 609f6985c686..9965b31e06ff 100644
--- a/sys-apps/kexec-tools/Manifest
+++ b/sys-apps/kexec-tools/Manifest
@@ -1,3 +1,4 @@
DIST kexec-tools-2.0.17.tar.xz 290612 BLAKE2B 57ec5b5ed33a5c5bbe433099d6e80663717c8a086bdb8b95f4a1d81fd7e546619c0064698454dc79f489313f98696ee6dee4cafbc8b1b93db5c7909cdf7a6234 SHA512 e0f254ca2b26fa02cb61ba9a0735423b26bac2693fbd920eaf7cc2822c298de958bd65f7c37947ca1f6811a3752a58f7cf8aa903494f0109ea76b7159a037fa6
DIST kexec-tools-2.0.18.tar.xz 289816 BLAKE2B b894a5c563810b0a537a3837e902a8d1a3b903c2028393047d6e28d125582f82a4f7ad7c192857f7f58c2fb045deb39e6caf115434c8ba826c705d1363c6b683 SHA512 a4142e703a752eb270da29f02ea4fb213f3f4f965e73bb483c388a378821094317a4c63406ab0afe118f79eb168ff63b9d2d9530551c984592165430e269d697
DIST kexec-tools-2.0.19.tar.xz 292348 BLAKE2B c9827d77c82f11351086f4cdf4bacd076a03c744969952706ffd6f17395f28fba2437dac976e12e8e5648ca09fac6ff241daf9b8d3fee215519ded9f18441ff0 SHA512 68b15fe46f9633d55c5ae51a6e7114b0c66bd8f4fe81197f581121939a7b21990a2eea89a0961ac6eb7af364ba0d3981ea504df81c7b4cc0b288ca6ac896730f
+DIST kexec-tools-2.0.20-rc1.tar.xz 296624 BLAKE2B bb30a4179f1884848c5fc04a376dae570eb18a20a4e5fb87f339c2270c1ded13e7c73436ba9869c8bd93eff158560f9f5625d533819a243bda328ca916ec6cb8 SHA512 ffb518fd51cc7b38e72d45a7b14aaf8cf5b8743968c654c4f6fb6123f3d0b5643657f1ada565d69aacdc292e4deac2afeeb4513e91bde8fb81c96ae1f4365f02
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.20_rc1.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.20_rc1.ebuild
new file mode 100644
index 000000000000..a96230eff795
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.20_rc1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic libtool linux-info systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
+else
+ SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P/_/-}.tar.xz"
+ [[ "${PV}" == *_rc* ]] || \
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="booke lzma xen zlib"
+
+REQUIRED_USE="lzma? ( zlib )"
+
+DEPEND="
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+CONFIG_CHECK="~KEXEC"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
+ "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
+)
+
+pkg_setup() {
+ # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
+ export ASFLAGS="${CCASFLAGS}"
+}
+
+src_prepare() {
+ default
+ if [[ "${PV}" == 9999 ]] ; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
+ filter-flags '-mindirect-branch=thunk*'
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with booke)
+ $(use_with lzma)
+ $(use_with xen)
+ $(use_with zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ newinitd "${FILESDIR}"/kexec.init-2.0.13-r1 kexec
+ newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
+
+ insinto /etc
+ doins "${FILESDIR}"/kexec.conf
+
+ insinto /etc/kernel/postinst.d
+ doins "${FILESDIR}"/90_kexec
+
+ systemd_dounit "${FILESDIR}"/kexec.service
+}
+
+pkg_postinst() {
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "For systemd support the new config file is"
+ elog " /etc/kexec.conf"
+ elog "Please adopt it to your needs as there is no autoconfig anymore"
+ fi
+}