summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-18 12:09:26 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-18 13:50:30 -0400
commit1925103bae2ec4d4d908fac69cd98ce67ae8f852 (patch)
tree2095001902f3bb8ab99b3d4cb9fa2d97e171f358
parentgnome-extra/gnome-contacts: Version bump to 44.0 (diff)
downloadgentoo-1925103b.tar.gz
gentoo-1925103b.tar.bz2
gentoo-1925103b.zip
net-misc/gnome-connections: Version bump to 44.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30208 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-misc/gnome-connections/Manifest1
-rw-r--r--net-misc/gnome-connections/gnome-connections-44.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/gnome-connections/Manifest b/net-misc/gnome-connections/Manifest
index a9ceef84cbab..ddd60768bfa8 100644
--- a/net-misc/gnome-connections/Manifest
+++ b/net-misc/gnome-connections/Manifest
@@ -1,2 +1,3 @@
DIST gnome-connections-43.0.tar.xz 3992760 BLAKE2B 16ff3cc5d587a6169fdf749ae6e743cd0fbec2b6e127c684ec42ba17da6e73d1d66ef4ef621d01452d21230dc8c99bc27678ec0364b9522b5685cec4b9c69445 SHA512 cd9d53f2e4b8e679992c5a65aa89554d1b840174ecf0f75f103265ebc2f07f63f210da4ef7e3c36af8b5fe761ec9ae4711eb92f5f40ae00225fcd9f2f8a9157b
+DIST gnome-connections-44.0.tar.xz 3998876 BLAKE2B 062769eafddb52da9962a59c11697205a0370d890425488a29d1bec2d4f2ba62041ff7d271d9bc7aae1a4fe108fa617864eea63755a6c02de07b340329dd2e5c SHA512 8193877175e5d553ada0b0c7985ee2029c85d0cb2fde16d5a47b9c6c0027deb22c4d1c8f4b2188ab430f3702318b2c1a229b0297a1e90aea45697e733733b3e9
DIST gnome-connections-44.rc.tar.xz 3998264 BLAKE2B a6d44c699e6698cba6b794cd0f36db971a8fc59bad4b4fe8f9b2a9b4c5be2eb66368c5dac0c4321195a1f3b30d1ac7196d76284ff01ab2806b8fad462f32a7e9 SHA512 8c23725340595fc0e3642a362e539e0f87b6908d0b35d4871a61984c40523f3c30dec1bdff7f68bc04c8d89fea742c91f5c5c3f2e389039e0c295cb33d661c23
diff --git a/net-misc/gnome-connections/gnome-connections-44.0.ebuild b/net-misc/gnome-connections/gnome-connections-44.0.ebuild
new file mode 100644
index 000000000000..325726aeadc2
--- /dev/null
+++ b/net-misc/gnome-connections/gnome-connections-44.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A remote desktop client for the GNOME desktop environment"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/connections"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/gobject-introspection
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=net-libs/gtk-vnc-0.4.4[pulseaudio,vala]
+ >=gui-libs/libhandy-1.6.0:1[vala]
+ >=dev-libs/libxml2-2.7.8
+ app-crypt/libsecret[vala]
+
+ >=net-misc/freerdp-2.0.0:0=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/glib
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}