summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-28 23:09:49 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-28 23:10:44 +0100
commit192df901c43bc541322b48283b76fa36f4909d4b (patch)
tree3717abd7dba56cd0d403f13b0f113352d511e9d4
parentkernel-install.eclass: Include a RDEP on libelf (diff)
downloadgentoo-192df901.tar.gz
gentoo-192df901.tar.bz2
gentoo-192df901.zip
xfce-extra/xfce4-time-out-plugin: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-time-out-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-time-out-plugin/Manifest b/xfce-extra/xfce4-time-out-plugin/Manifest
index f0cabf32412b..ef8374f81b60 100644
--- a/xfce-extra/xfce4-time-out-plugin/Manifest
+++ b/xfce-extra/xfce4-time-out-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-time-out-plugin-1.1.1.tar.bz2 405970 BLAKE2B 0e0d94bdb80e3cd8aa3304489d8122f9e0161db57c77c80893f97bc2dc2d578d89e190c56891abcebd95cd7cf9d58e2ba768540af8817b861dded381c6550a74 SHA512 463d210eb6cfaa79c3470b44e7fb42ab44ce8fec0e403d8c71344a5bbc68af29e0da0fe759471ed873637114adf947699ecbaea1129f36e2dd6dc56db0c2ca87
+DIST xfce4-time-out-plugin-1.1.2.tar.bz2 409221 BLAKE2B 75a6f646badb936a803d8e6a8c9c25c85fa76f96fa82bae742724d3b52a68c49f81f58600a91de6ceb0f85220aa2d6b3a3ae2525a38e4f8a5fd78d4fbc6f0dfc SHA512 08e50db9daafd9a2ba60e9d5767cddba83df34d8a261df71b7bb9ae632576f4dfd6252c2a83ec8f9a037284b0adc65751ba36d54ea9d14b85906fdc85d5b86ff
diff --git a/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.2.ebuild b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.2.ebuild
new file mode 100644
index 000000000000..c98032bc3cce
--- /dev/null
+++ b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in to take periodical breaks from the computer"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-time-out-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}