summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-08 15:53:17 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-08 15:57:05 +0200
commit192f7cd8265aae430a4ddedb245988f15075adae (patch)
tree393302315794f01daf3bbde0ec103584c82cabed
parentdev-python/tdaemon: Remove last-rited pkg (diff)
downloadgentoo-192f7cd8265aae430a4ddedb245988f15075adae.tar.gz
gentoo-192f7cd8265aae430a4ddedb245988f15075adae.tar.bz2
gentoo-192f7cd8265aae430a4ddedb245988f15075adae.zip
dev-python/kiwi: Remove last-rited pkg
Closes: https://bugs.gentoo.org/526668
-rw-r--r--dev-python/kiwi/Manifest2
-rw-r--r--dev-python/kiwi/kiwi-1.9.39.2.ebuild44
-rw-r--r--dev-python/kiwi/kiwi-1.9.40.ebuild46
-rw-r--r--dev-python/kiwi/metadata.xml12
-rw-r--r--profiles/package.mask5
5 files changed, 0 insertions, 109 deletions
diff --git a/dev-python/kiwi/Manifest b/dev-python/kiwi/Manifest
deleted file mode 100644
index 3b85ef8964bf..000000000000
--- a/dev-python/kiwi/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST kiwi-gtk-1.9.39.2.tar.gz 678242 BLAKE2B 3bebe02af3b439fbd028bd6bef0ae5d9610df0afca4b0a2e671b152b73fb8fad37ffaf7c67eee2b228af1698a981a5e7bf35d075b534f209ec41b438dd9432de SHA512 fa54623bb95a7ebe03e87c10d3bb271bd98fa4f40f7244f399cf2f86bf9b2e257666fc58caa4cc83d91a3c7fcf06817886ef5cab1baff58c8cbfdf6cfd12a554
-DIST kiwi-gtk-1.9.40.tar.gz 675794 BLAKE2B d775bc826bcb336148dc2cae633301efccea43aa412e9e7fb1039f389bbbdb38baab6771d43f35cc3837dbed0b60d94ba70a215e6d7a55fc4b93e91f7fe50ba4 SHA512 1fa210bcf00eeb8513f1b3fde968a212ac79c286a50a09427b0e3dffc5e78d739e70101ba4a0086d2002ac6907bc40b0103604f486b72e1bec36c9912ae6f2b6
diff --git a/dev-python/kiwi/kiwi-1.9.39.2.ebuild b/dev-python/kiwi/kiwi-1.9.39.2.ebuild
deleted file mode 100644
index 7ae149f76646..000000000000
--- a/dev-python/kiwi/kiwi-1.9.39.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 versionator virtualx
-
-DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
-HOMEPAGE="https://launchpad.net/kiwi
- https://pypi.org/project/kiwi-gtk/"
-MY_PN="${PN}-gtk"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-RDEPEND=">=dev-python/setuptools-0.8[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.24[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- testing() {
- "${PYTHON}" -m unittest discover || die "tests failed"
- }
- VIRTUALX_COMMAND=virtualmake testing
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
- rmdir "${D}"usr/share/doc/${PF}/{api,howto} || die
-}
diff --git a/dev-python/kiwi/kiwi-1.9.40.ebuild b/dev-python/kiwi/kiwi-1.9.40.ebuild
deleted file mode 100644
index d0219774e889..000000000000
--- a/dev-python/kiwi/kiwi-1.9.40.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 versionator virtualx
-
-DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
-HOMEPAGE="https://launchpad.net/kiwi
- https://pypi.org/project/kiwi-gtk/"
-MY_PN="${PN}-gtk"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-RDEPEND=">=dev-python/setuptools-0.8[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.24[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # There is one fail of a test repeated 3 times in tests/test_ui.py however
- # they are shy with their bug tracker. The fail is not a failing of the package's core modules
- testing() {
- "${PYTHON}" -m unittest discover || die "tests failed"
- }
- VIRTUALX_COMMAND=virtualmake testing
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
- rmdir "${D}"usr/share/doc/${PF}/{api,howto} || die
-}
diff --git a/dev-python/kiwi/metadata.xml b/dev-python/kiwi/metadata.xml
deleted file mode 100644
index c05c28dbfd5b..000000000000
--- a/dev-python/kiwi/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">kiwi-gtk</remote-id>
- <remote-id type="launchpad">kiwi</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index d31cb090c5db..616ace9da9b9 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -303,11 +303,6 @@ dev-python/iconvcodec
# No reverse dependencies. Removal in 30 days. Bug #527176.
dev-python/django-evolution
-# Michał Górny <mgorny@gentoo.org> (26 Apr 2018)
-# Produces a lot of Pango warnings, then segfaults. Unmaintained.
-# No reverse dependencies. Removal in 30 days. Bug #526668.
-dev-python/kiwi
-
# Alexis Ballier <aballier@gentoo.org> (21 Apr 2018)
# Needs porting of revdeps
# See: https://bugs.gentoo.org/653678