summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-04 13:52:53 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-04 13:54:22 +0200
commit193ff1e6236c89f88b92ee7d4c4a86bcc89a3d96 (patch)
tree2d00260e7b76456d4ff21ed90df818ab296f8f6e
parentsys-apps/help2man: Removed old (diff)
downloadgentoo-193ff1e6236c89f88b92ee7d4c4a86bcc89a3d96.tar.gz
gentoo-193ff1e6236c89f88b92ee7d4c4a86bcc89a3d96.tar.bz2
gentoo-193ff1e6236c89f88b92ee7d4c4a86bcc89a3d96.zip
x11-misc/xfishtank: Version 2.5
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--x11-misc/xfishtank/Manifest1
-rw-r--r--x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch20
-rw-r--r--x11-misc/xfishtank/xfishtank-2.5.ebuild39
3 files changed, 50 insertions, 10 deletions
diff --git a/x11-misc/xfishtank/Manifest b/x11-misc/xfishtank/Manifest
index c0d925ad8a9b..ca1d5ddc5b56 100644
--- a/x11-misc/xfishtank/Manifest
+++ b/x11-misc/xfishtank/Manifest
@@ -1 +1,2 @@
DIST xfishtank-2.1tp.tar.gz 187513 BLAKE2B e2acec91ef52776bee82ea1b4df347b7fe509377687e74422d6dff81d7fce8a4009e4d0f45327a8401e4ae9782440d9f6478d1dd501c6e4e7d595d94b2d40b1a SHA512 641efa1104685d94589c2d9d365108308cb1b0dd238dbba6dc333c5922bda371536c0e26a63645351ac245a18f2386e4c47b4a1fc2a7f4b0400d37db846976a1
+DIST xfishtank-2.5.tar.gz 153464 BLAKE2B 0bb3121b84c3d08ea2251a70f9ad569e90fe6299ad3ee4942ec83d80483fcf4db0b0079161c28ff63461597f76b0d0532a65c1bde8aa821ff6bc92be189843f2 SHA512 1bfe16737bdbc2b7cf74abb98408bf632d8881f15753005424f84eba4afca756b07fa7ad424df800ee3f3e46e033b8f60142877bcd9a7e4e806e318ee283721f
diff --git a/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch b/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch
index 0a4a03503246..b00118631bee 100644
--- a/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch
+++ b/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch
@@ -1,5 +1,5 @@
---- xfishtank-2.1tp/read.c
-+++ xfishtank-2.1tp/read.c
+--- a/read.c
++++ b/read.c
@@ -1,5 +1,7 @@
#include <X11/Xlib.h>
#include <stdio.h>
@@ -8,16 +8,16 @@
#include "compact.h"
#include "medcut.h"
---- xfishtank-2.1tp/medcut.c
-+++ xfishtank-2.1tp/medcut.c
+--- a/medcut.c
++++ b/medcut.c
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include "medcut.h"
#define RED 0
---- xfishtank-2.1tp/xfish.c
-+++ xfishtank-2.1tp/xfish.c
+--- a/xfish.c
++++ b/xfish.c
@@ -46,6 +46,9 @@
#endif
@@ -51,8 +51,8 @@
timeout.tv_sec = seconds;
timeout.tv_usec = (seconds - timeout.tv_sec) * 1000000.0;
select(0, &fds, &fds, &fds, &timeout);
---- xfishtank-2.1tp/makeh.c
-+++ xfishtank-2.1tp/makeh.c
+--- a/makeh.c
++++ b/makeh.c
@@ -1,6 +1,6 @@
-
+#include <stdlib.h>
@@ -62,8 +62,8 @@
main()
{
FILE *fp;
---- xfishtank-2.1tp/gifread.c
-+++ xfishtank-2.1tp/gifread.c
+--- a/gifread.c
++++ b/gifread.c
@@ -56,6 +56,8 @@
#include <X11/Xlib.h>
diff --git a/x11-misc/xfishtank/xfishtank-2.5.ebuild b/x11-misc/xfishtank/xfishtank-2.5.ebuild
new file mode 100644
index 000000000000..8ea5a3d929a8
--- /dev/null
+++ b/x11-misc/xfishtank/xfishtank-2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Turns your root window into an aquarium"
+HOMEPAGE="https://jim.rees.org/computers/xfishtank.html"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ x11-misc/imake
+"
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ ${PN}
+}