summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam+gentoo@gmail.com>2019-05-04 08:48:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-04 08:59:29 +0200
commit1956ce92abd8865e029a0e924d8fc3187c3a9990 (patch)
tree8d8450bb1ac532641622e506f36c4042030880c3
parentdev-ruby/elasticsearch: add 6.3.1 (diff)
downloadgentoo-1956ce92.tar.gz
gentoo-1956ce92.tar.bz2
gentoo-1956ce92.zip
dev-libs/libbytesize: Added "python" USE flag
Closes: https://bugs.gentoo.org/684938 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/libbytesize/libbytesize-2.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/libbytesize/libbytesize-2.0.ebuild b/dev-libs/libbytesize/libbytesize-2.0.ebuild
index 8e8c95ae0808..60b36285a575 100644
--- a/dev-libs/libbytesize/libbytesize-2.0.ebuild
+++ b/dev-libs/libbytesize/libbytesize-2.0.ebuild
@@ -13,15 +13,15 @@ SRC_URI="https://github.com/storaged-project/${PN}/archive/${PV}.tar.gz -> ${P}.
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc test tools"
+IUSE="doc python test tools"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
- ${PYTHON_DEPS}
dev-libs/gmp:0=
dev-libs/mpfr:=
dev-libs/libpcre2
+ python? ( ${PYTHON_DEPS} )
"
DEPEND="
@@ -45,7 +45,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --with-python3
+ $(use_with python python3)
$(use_with doc gtk-doc)
$(use_with tools)
)
@@ -54,6 +54,6 @@ src_configure() {
src_install() {
default
- python_optimize
+ use python && python_optimize
find "${ED}" -name "*.la*" -delete || die
}