summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2023-01-25 13:58:00 +0600
committerFlorian Schmaus <flow@gentoo.org>2023-03-09 11:53:58 +0100
commit195bde1f0ccb747b72a492cfdbe6be0270e5caf8 (patch)
tree621aa84d074c8e4d95bf135c2764fffd528012e7
parentdev-lang/zig-bin: slotting (diff)
downloadgentoo-195bde1f0ccb747b72a492cfdbe6be0270e5caf8.tar.gz
gentoo-195bde1f0ccb747b72a492cfdbe6be0270e5caf8.tar.bz2
gentoo-195bde1f0ccb747b72a492cfdbe6be0270e5caf8.zip
sys-fs/ncdu: adjust ebuild for slotted Zig
Closes: https://github.com/gentoo/gentoo/pull/29257 Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-fs/ncdu/ncdu-2.2.2-r1.ebuild136
1 files changed, 136 insertions, 0 deletions
diff --git a/sys-fs/ncdu/ncdu-2.2.2-r1.ebuild b/sys-fs/ncdu/ncdu-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..22518d804b8f
--- /dev/null
+++ b/sys-fs/ncdu/ncdu-2.2.2-r1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit verify-sig edo
+
+DESCRIPTION="NCurses Disk Usage"
+HOMEPAGE="https://dev.yorhel.nl/ncdu"
+SRC_URI="
+ https://dev.yorhel.nl/download/${P}.tar.gz
+ verify-sig? ( https://dev.yorhel.nl/download/${P}.tar.gz.asc )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+EZIG_MIN="0.10.0"
+EZIG_MAX_EXCLUSIVE="0.11.0"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ || ( dev-lang/zig:0.10 dev-lang/zig-bin:0.10 )
+ virtual/pkgconfig
+ dev-lang/perl
+ verify-sig? ( sec-keys/openpgp-keys-yorhel )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/yoranheling.asc
+
+# see https://github.com/ziglang/zig/issues/3382
+# For now, Zig doesn't support CFLAGS/LDFLAGS/etc.
+QA_FLAGS_IGNORED="usr/bin/ncdu"
+
+# Many thanks to Florian Schmaus (Flowdalic)!
+# Adapted from https://github.com/gentoo/gentoo/pull/28986
+# Set the EZIG environment variable.
+zig-set_EZIG() {
+ [[ -n ${EZIG} ]] && return
+
+ if [[ -n ${EZIG_OVERWRITE} ]]; then
+ export EZIG="${EZIG_OVERWRITE}"
+ return
+ fi
+
+ local candidates candidate selected selected_ver
+
+ candidates=$(compgen -c zig-)
+
+ for candidate in ${candidates}; do
+ if [[ ! ${candidate} =~ zig(-bin)?-([.0-9]+) ]]; then
+ continue
+ fi
+
+ local ver
+ if (( ${#BASH_REMATCH[@]} == 3 )); then
+ ver="${BASH_REMATCH[2]}"
+ else
+ ver="${BASH_REMATCH[1]}"
+ fi
+
+ if [[ -n ${EZIG_EXACT_VER} ]]; then
+ ver_test "${ver}" -ne "${EZIG_EXACT_VER}" && continue
+
+ selected="${candidate}"
+ selected_ver="${ver}"
+ break
+ fi
+
+ if [[ -n ${EZIG_MIN} ]] \
+ && ver_test "${ver}" -lt "${EZIG_MIN}"; then
+ # Candidate does not satisfy EZIG_MIN condition.
+ continue
+ fi
+
+ if [[ -n ${EZIG_MAX_EXCLUSIVE} ]] \
+ && ver_test "${ver}" -ge "${EZIG_MAX_EXCLUSIVE}"; then
+ # Candidate does not satisfy EZIG_MAX_EXCLUSIVE condition.
+ continue
+ fi
+
+ if [[ -n ${selected_ver} ]] \
+ && ver_test "${selected_ver}" -gt "${ver}"; then
+ # Candidate is older than the currently selected candidate.
+ continue
+ fi
+
+ selected="${candidate}"
+ selected_ver="${ver}"
+ done
+
+ if [[ -z ${selected} ]]; then
+ die "Could not find (suitable) zig installation in PATH"
+ fi
+
+ export EZIG="${selected}"
+ export EZIG_VER="${ver}"
+}
+
+# Invoke zig with the optionally provided arguments.
+ezig() {
+ zig-set_EZIG
+
+ # Unfortunately, we cannot add more args here, since syntax is different
+ # for every subcommands. Yes, even target/cpu :( f.i. :
+ # -target/-mcpu for zig build-exe vs -Dtarget/-Dcpu for zig build-
+ # -OReleaseSafe for zig build-exe vs -DReleaseSafe for zig build
+ # (or even none, if hardcoded by upstream so choice is -Drelease=true/false)
+ # Ofc we can patch this, but still...
+
+ edo "${EZIG}" "${@}"
+}
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.asc}
+ fi
+ default
+}
+
+src_compile() {
+ ezig build -Drelease-fast
+ edo pod2man --center "ncdu manual" --release "ncdu-${PV}" ncdu.pod >ncdu.1
+}
+
+src_test() {
+ ezig build test -Drelease-fast
+}
+
+src_install() {
+ emake PREFIX="${ED}"/usr install
+
+ dodoc README.md ChangeLog
+}