summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-19 18:42:42 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-19 19:59:49 +0100
commit196e7cba93f1b6f795f5f3ec3f0aad272d6b97be (patch)
treeef4e10d7086feacca019da25a8ee550e4d297e11
parentdev-cpp/magic_enum: Keyword 0.9.5 ppc, #920328 (diff)
downloadgentoo-196e7cba93f1b6f795f5f3ec3f0aad272d6b97be.tar.gz
gentoo-196e7cba93f1b6f795f5f3ec3f0aad272d6b97be.tar.bz2
gentoo-196e7cba93f1b6f795f5f3ec3f0aad272d6b97be.zip
app-containers/earthly: bump to 0.7.23
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.7.23.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index aed1b2b04ab9..579fe9ed764d 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -2,3 +2,5 @@ DIST earthly-0.7.21-deps.tar.xz 153233840 BLAKE2B e5f2590997eb839232a84bc75c787a
DIST earthly-0.7.21.tar.gz 7788611 BLAKE2B 697194102a3d0af16744b42f2489a38db588ddfcc4d9e3358f259733500a69c188e11e71f6f5e9900a36c91b84d0314a6defdea339d4882f0490f2a9a4119408 SHA512 408298019bdb5797d96edd008b8e430de2cce701c93cb2f55a0faf5a9a4865e26283d8a80b82163e8b51ef82518ec35a7530aa887d598c15027243f6008954d1
DIST earthly-0.7.22-deps.tar.xz 156575120 BLAKE2B d10d38f62ddd134705fd840a5912d69f0ce50aa39d6fba9ce1e23496af2a19034886eb47521333ad6fd0b36addba59b465eb9b74e585ae79505a47baaa5487de SHA512 c3f6648d0d51a4195c191c6ad6db92adec5e7e488cb63c0be49338445d5d0a22a1d49792d88a297689a23b38fcd0e8eab701ad1419c19d03d627c3ec92414b56
DIST earthly-0.7.22.tar.gz 7813193 BLAKE2B f34b938776379f2ba0722757d53646d89841ed0dc35dc106f79f69166e3ab12c78b29913a5711ae403a940dbfab9526c306b773aa962bbb4b5bdc27fb04fce23 SHA512 62bb8c477589d5d3492fe5c2c2534d5f56afa4aca8862bee6691e867d3dd6fb904ecbe08c02a0058968c98b1b75beb43caf4f7b6997a00c2d73fc9614516658d
+DIST earthly-0.7.23-deps.tar.xz 157140928 BLAKE2B 493c7dce3e79f94659e99501020c07232a2d6ff78a055209b1b42be8615e38e01dacef4ceb50a80ed26e597de4dbb892fee2d54f6721fd5af62c86a0a9197d45 SHA512 a278077be794a1085105271fc3e031c02079e2b4f45c7220b3114df72ba26758758d5c0f1171ff861feb1c305765952494bf1afe95dcc469d2b9c6aad13fe7b9
+DIST earthly-0.7.23.tar.gz 8023353 BLAKE2B 458850b26a2730eb10ae3912f249d6ba9fdf81ed0c734f568ebf2cbaf5da005d258d38a089d452d42628d071d0b07f73e4f73cb29e7a02c406c1ea394d22ae97 SHA512 be524a6ab86ad3cff307d990f3645007cde673383cbaf132ebc6ab9e7052e8d13e163e958353041151d9fe6dc987ab75372dbf061a8413a932408a844cfe1007
diff --git a/app-containers/earthly/earthly-0.7.23.ebuild b/app-containers/earthly/earthly-0.7.23.ebuild
new file mode 100644
index 000000000000..95c419e4b2a8
--- /dev/null
+++ b/app-containers/earthly/earthly-0.7.23.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
+if [[ "${PV}" == 0.7.23 ]] ; then
+ GIT_COMMIT_SHA=e77372274b09b5e5f8a42f1b6ac264f7149c4924
+else
+ die 'Could not detect "GIT_COMMIT_SHA", please update the ebuild.'
+fi
+
+inherit go-module
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_compile() {
+ mkdir -p bin || die
+
+ local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${GIT_COMMIT_SHA}
+ -X main.Version=v${PV}
+ "
+ local -a go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o bin
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}