summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2020-09-02 20:33:17 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-07 11:41:27 +0300
commit1971e0140be8e6d90d43356c3f98af6eed816041 (patch)
tree0035905b383fccad6a443b2bc1f57efebcfb3e31
parentdev-python/ordered-set: vbump 4.0.2 (diff)
downloadgentoo-1971e014.tar.gz
gentoo-1971e014.tar.bz2
gentoo-1971e014.zip
dev-python/pylatex: vbump 1.4.0
Use pytest as test runner Put S variable in right place Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17388 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/pylatex/Manifest1
-rw-r--r--dev-python/pylatex/pylatex-1.4.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pylatex/Manifest b/dev-python/pylatex/Manifest
index 9a089da0738d..65c065d5f204 100644
--- a/dev-python/pylatex/Manifest
+++ b/dev-python/pylatex/Manifest
@@ -1 +1,2 @@
DIST pylatex-1.3.3.tar.gz 300639 BLAKE2B ac8fad8fa7e6e821cda168f3ae8ffb5acec21d688761b153ef2f9383b6a2f2ac7daea65f04389eb1ba3152fc50176d73cb814a78d2b5250ead2c6647eb96635a SHA512 12f51805996d84840f68844b79384ce4d2c29dde4db06f73b8887fe012abeaa4b9c5cf5e449132e626132b50ba26f014a899d548e3c0def25289671fd92e41a6
+DIST pylatex-1.4.0.tar.gz 301148 BLAKE2B 4d1fa6add43556b7b2c1ff13b3bc2130d06018499197c3d1f40c9180f4346e774d69c2a356d5eab6c8686957ebafac71a78506553cf7cd3cd57d03c0e0ffffd1 SHA512 0d9ab3e733c50b5a4dd7a6758193645c5532c9153972bbed244e3f7e2d6a946bd36af428197f9cdd1a3256f4cc0db5dc78248973f9b330684ce8651c4a59ad91
diff --git a/dev-python/pylatex/pylatex-1.4.0.ebuild b/dev-python/pylatex/pylatex-1.4.0.ebuild
new file mode 100644
index 000000000000..f7b9a7e488dc
--- /dev/null
+++ b/dev-python/pylatex/pylatex-1.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="PyLaTeX"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A Python library for creating LaTeX files and snippets"
+HOMEPAGE="https://github.com/JelteF/PyLaTeX"
+SRC_URI="https://github.com/JelteF/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/ordered-set[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+BDEPEND+="
+ test? (
+ dev-python/quantities[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ app-text/texlive
+ dev-texlive/texlive-latexextra
+ )"
+
+python_install_all() {
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/"${PF}"/examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "Optional dependencies:"
+ optfeature "compiling generated files" "app-text/texlive dev-texlive/texlive-latexextra dev-texlive/texlive-mathscience"
+ optfeature "matplotlib support" dev-python/matplotlib
+ optfeature "numpy support" dev-python/numpy
+ optfeature "quantities support" dev-python/quantities
+}