summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-26 03:09:18 +0000
committerSam James <sam@gentoo.org>2022-02-26 03:43:22 +0000
commit1979dbb2dea9e3f5c035443a0af0ba5091e638dd (patch)
tree644ec7b52e5705d915c68e69b91291099ca921ac
parentdev-libs/libvterm: add 0.2 (unkeyworded) (diff)
downloadgentoo-1979dbb2.tar.gz
gentoo-1979dbb2.tar.bz2
gentoo-1979dbb2.zip
app-editors/neovim: update tree-sitter lower bound, other dep bounds
Closes: https://bugs.gentoo.org/834039 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/neovim/neovim-0.6.1-r1.ebuild (renamed from app-editors/neovim/neovim-0.6.1.ebuild)16
-rw-r--r--app-editors/neovim/neovim-9999.ebuild18
2 files changed, 19 insertions, 15 deletions
diff --git a/app-editors/neovim/neovim-0.6.1.ebuild b/app-editors/neovim/neovim-0.6.1-r1.ebuild
index 2583a834c2fb..d7838343d030 100644
--- a/app-editors/neovim/neovim-0.6.1.ebuild
+++ b/app-editors/neovim/neovim-0.6.1-r1.ebuild
@@ -31,13 +31,15 @@ RESTRICT="!test? ( test ) test"
# Upstream build scripts invoke the Lua interpreter
BDEPEND="${LUA_DEPS}
- dev-util/gperf
+ >=dev-util/gperf-3.1
virtual/libiconv
virtual/libintl
virtual/pkgconfig
"
+# Check https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt for
+# new dependency bounds and so on on bumps (obviously adjust for right branch/tag).
DEPEND="${LUA_DEPS}
- dev-lua/luv[${LUA_SINGLE_USEDEP}]
+ >=dev-lua/luv-1.42.0[${LUA_SINGLE_USEDEP}]
$(lua_gen_cond_dep '
dev-lua/lpeg[${LUA_USEDEP}]
dev-lua/mpack[${LUA_USEDEP}]
@@ -45,12 +47,12 @@ DEPEND="${LUA_DEPS}
$(lua_gen_cond_dep '
dev-lua/LuaBitOp[${LUA_USEDEP}]
' lua5-{1,2})
- dev-libs/libuv:0=
- >=dev-libs/libvterm-0.1.2
- dev-libs/msgpack:0=
- dev-libs/tree-sitter:=
+ >=dev-libs/libuv-1.42.0:=
+ >=dev-libs/libvterm-0.1.4
+ >=dev-libs/msgpack-3.0.0:=
+ >=dev-libs/tree-sitter-0.20.1:=
tui? (
- dev-libs/libtermkey
+ >=dev-libs/libtermkey-0.22
>=dev-libs/unibilium-2.0.0:0=
)
"
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 54ffbbed750b..69b26947a582 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,13 +31,15 @@ RESTRICT="!test? ( test ) test"
# Upstream build scripts invoke the Lua interpreter
BDEPEND="${LUA_DEPS}
- dev-util/gperf
+ >=dev-util/gperf-3.1
virtual/libiconv
virtual/libintl
virtual/pkgconfig
"
+# Check https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt for
+# new dependency bounds and so on on bumps (obviously adjust for right branch/tag).
DEPEND="${LUA_DEPS}
- dev-lua/luv[${LUA_SINGLE_USEDEP}]
+ >=dev-lua/luv-1.43.0[${LUA_SINGLE_USEDEP}]
$(lua_gen_cond_dep '
dev-lua/lpeg[${LUA_USEDEP}]
dev-lua/mpack[${LUA_USEDEP}]
@@ -45,12 +47,12 @@ DEPEND="${LUA_DEPS}
$(lua_gen_cond_dep '
dev-lua/LuaBitOp[${LUA_USEDEP}]
' lua5-{1,2})
- dev-libs/libuv:0=
- >=dev-libs/libvterm-0.1.2
- dev-libs/msgpack:0=
- dev-libs/tree-sitter:=
+ >=dev-libs/libuv-1.43.0:=
+ >=dev-libs/libvterm-0.1.4
+ >=dev-libs/msgpack-3.0.0:=
+ >=dev-libs/tree-sitter-0.20.1:=
tui? (
- dev-libs/libtermkey
+ >=dev-libs/libtermkey-0.22
>=dev-libs/unibilium-2.0.0:0=
)
"