summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-30 09:55:26 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-30 09:55:26 +0100
commit197d3f7ef43b1f3fd714c2ea2e9aacf37b0176a4 (patch)
tree9849a1deeba3c8f9c2b0e00a700340685e994711
parentdev-python/alembic: Bump to 1.5.3 (diff)
downloadgentoo-197d3f7e.tar.gz
gentoo-197d3f7e.tar.bz2
gentoo-197d3f7e.zip
dev-python/slixmpp: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/slixmpp-1.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index 4ea9f8f47eb8..96fc03add985 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1,2 +1,3 @@
DIST slixmpp-1.4.2.tar.gz 864608 BLAKE2B 9689b274a9c787174248c094329ea33783627a45ef39708a611013454953de4fa8799ca5a35950a3f3ed49bebf5c56f6f2bea079bcc2a3dce7d2648bfd812371 SHA512 3b3356352af8d7ec8cca15210c0524ce0bb5e313d8c5455bec13e82aec261f6d094a99df9f08642418a0e4abea4ee1ff607e42e1c166b9be1c26534b690c330b
DIST slixmpp-1.5.2.tar.gz 886383 BLAKE2B 6b5ed074ab182f449bf7d2919c241694ea4ff24567546c50a3d228af7708826fb9bfd89b4fccf8a31ae2909399b57caa752a71c187cffbe133bab13b41da814f SHA512 4f377246526c03ae02ece370ba8c9fa7c26a89eca7a012a1a89b8186b6c226d72287c15a7668ca85bfc8f2200765406dbc0fa9cb0e358c3755f551df8eb0d59f
+DIST slixmpp-1.7.0.tar.gz 931610 BLAKE2B bb84e33681cc2701dbfc164ad4e727236dbe5fe1206a4c4e93843f9cbd870b6b3efb03b89ae61ddde4249c4928a81edaea9caf1d04b88e3b5cb0e81b1fe3fad7 SHA512 1f70f6b0419877865b80213a50ba181639cbf64fd808695d7a95eae460635a537492f72bed0e6d77d33dc9a5da4ec505da4cd44526bdee2a39b56b98a9974cfc
diff --git a/dev-python/slixmpp/slixmpp-1.7.0.ebuild b/dev-python/slixmpp/slixmpp-1.7.0.ebuild
new file mode 100644
index 000000000000..0f5e88aa5f6c
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ net-dns/libidn
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
+}