summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 15:21:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 15:25:27 +0200
commit199037a9dc0d6e6a54f5ac30f6249255a2c142bd (patch)
tree60707683d7dcd1c6053c9c998d866200aca9aa51
parentdev-ml/ocaml-compiler-libs: Initial import. Ebuild by me. (diff)
downloadgentoo-199037a9.tar.gz
gentoo-199037a9.tar.bz2
gentoo-199037a9.zip
dev-ml/ppx_ast: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ml/ppx_ast/Manifest1
-rw-r--r--dev-ml/ppx_ast/metadata.xml8
-rw-r--r--dev-ml/ppx_ast/ppx_ast-0.9.1.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ppx_ast/Manifest b/dev-ml/ppx_ast/Manifest
new file mode 100644
index 000000000000..650f2f587a74
--- /dev/null
+++ b/dev-ml/ppx_ast/Manifest
@@ -0,0 +1 @@
+DIST ppx_ast-0.9.1.tar.gz 86802 SHA256 62e08c4383226eeb0e9986871a4fa2a2e90c4bf54538b4a085b0b501631314c8 SHA512 4a5a9fb47282877763ecf9638e67bcd1b57110c1acfcf446703ed335b9fa5aaa1521c55a75fce6025f91e715f9c4522b695444dde4d3ffa7feed79560e399ad7 WHIRLPOOL 50f9523a30f7372a0a8a00d2922e8bfb0a627824dfccfd6ff36cd434c7455011942fc64e516cc51a4258f2efc786d6c7f73838a88ea4bc33e5c54ba5cb0afc93
diff --git a/dev-ml/ppx_ast/metadata.xml b/dev-ml/ppx_ast/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ppx_ast/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_ast/ppx_ast-0.9.1.ebuild b/dev-ml/ppx_ast/ppx_ast-0.9.1.ebuild
new file mode 100644
index 000000000000..a37732478520
--- /dev/null
+++ b/dev-ml/ppx_ast/ppx_ast-0.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="AST used in Jane Street ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_ast"
+SRC_URI="https://github.com/janestreet/ppx_ast/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ocaml-compiler-libs:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}