summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-30 19:31:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-30 19:31:14 +0100
commit19a8e4975d37091c2ad63cbb9a09d4414440d4bb (patch)
treec24e763ef8f1e05ebc49204c5b7f9e0aa9ae4400
parentdev-python/pytest-order: Remove old (diff)
downloadgentoo-19a8e4975d37091c2ad63cbb9a09d4414440d4bb.tar.gz
gentoo-19a8e4975d37091c2ad63cbb9a09d4414440d4bb.tar.bz2
gentoo-19a8e4975d37091c2ad63cbb9a09d4414440d4bb.zip
dev-python/pytest-recording: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-recording/Manifest1
-rw-r--r--dev-python/pytest-recording/pytest-recording-0.13.0.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pytest-recording/Manifest b/dev-python/pytest-recording/Manifest
index d7496e575141..ee9bd183e1f4 100644
--- a/dev-python/pytest-recording/Manifest
+++ b/dev-python/pytest-recording/Manifest
@@ -1,2 +1 @@
-DIST pytest_recording-0.13.0.tar.gz 25027 BLAKE2B c325aaf809617886e85c3fa597c36858c7e1a9cb1552a18c8ee27f5a7479b66469b61bce51ceb14fc9dd5fa420c20803ed016875eef1a0cf05de5293ead24bfc SHA512 2e9ab39971d89f838f2d778d1d80fdb5519b39855a69019eeeb22d69ca3c92ecb14a7eda7b55ec37ea07fae0c3316c9c16932a0afcf0abe0dbfefc31fe23bd68
DIST pytest_recording-0.13.1.tar.gz 24987 BLAKE2B 70c7d65823e1a6507353dcab61659a4fe05a4f3d81471dfa3818ca34f6b6c1c22444ee6c1d04b67e87db93ffba63e8bf091beb7d3f60723bc1f7fa8dfde641cd SHA512 1f815b45361165a9fa2655c0cfb5a69193a556e748dc5d69aac0f49a36e943a60a990c3f503a29aae58f9409661f5f47041a30766fb1b5276789eec255b1556b
diff --git a/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild b/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
deleted file mode 100644
index 2a204e0b665c..000000000000
--- a/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A pytest plugin to record network interactions via VCR.py"
-HOMEPAGE="
- https://pypi.org/project/pytest-recording/
- https://github.com/kiwicom/pytest-recording/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-RDEPEND="
- >=dev-python/pytest-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/vcrpy-2.0.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test () {
- local EPYTEST_DESELECT=(
- # Internet
- # https://github.com/kiwicom/pytest-recording/issues/131
- tests/test_blocking_network.py::test_block_network_with_allowed_hosts
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_recording.plugin
- PYTEST_PLUGINS+=,pytest_httpbin.plugin,pytest_mock
- epytest
-}