summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-27 11:51:02 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-27 12:07:13 +0100
commit19acd9fdb8d2e79fd982c9e3b9723d82906c6a44 (patch)
treec0b4b7993af4c8b10dcaec1ed5614c542b2bee20
parentdev-python/python-zipstream: treeclean (diff)
downloadgentoo-19acd9fdb8d2e79fd982c9e3b9723d82906c6a44.tar.gz
gentoo-19acd9fdb8d2e79fd982c9e3b9723d82906c6a44.tar.bz2
gentoo-19acd9fdb8d2e79fd982c9e3b9723d82906c6a44.zip
dev-python/PyContracts: treeclean
Closes: https://bugs.gentoo.org/834555 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-python/PyContracts/Manifest1
-rw-r--r--dev-python/PyContracts/PyContracts-1.8.14-r1.ebuild39
-rw-r--r--dev-python/PyContracts/files/PyContracts-1.8.14-fix-py3.10.patch150
-rw-r--r--dev-python/PyContracts/metadata.xml13
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 204 deletions
diff --git a/dev-python/PyContracts/Manifest b/dev-python/PyContracts/Manifest
deleted file mode 100644
index 11d91dde1c1b..000000000000
--- a/dev-python/PyContracts/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST PyContracts-1.8.14.tar.gz 92346 BLAKE2B 507fdfb313347d6650f21326b6b70b73f17cd702f25d06d97e5d84f84c9bf7f23cceb48d918727158d02081115344a4194e307caed59510265dacbf267774ab4 SHA512 95f8c76e35cc7549fefa069d9c354fc1d4a55dcab0f3fd322cb86aed92c7bfa75a06eabb7540ff991d590a90cdec781906b856291002a82ee5ab0072cdcf6ccd
diff --git a/dev-python/PyContracts/PyContracts-1.8.14-r1.ebuild b/dev-python/PyContracts/PyContracts-1.8.14-r1.ebuild
deleted file mode 100644
index d77287470a4a..000000000000
--- a/dev-python/PyContracts/PyContracts-1.8.14-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Declare constraints on function parameters and return values"
-HOMEPAGE="https://andreacensi.github.io/contracts/ https://pypi.org/project/PyContracts/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- ' 'python*' )
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-distutils_enable_tests nose
-
-pkg_postinst() {
- optfeature "constraints on numpy arrays" dev-python/numpy
-}
diff --git a/dev-python/PyContracts/files/PyContracts-1.8.14-fix-py3.10.patch b/dev-python/PyContracts/files/PyContracts-1.8.14-fix-py3.10.patch
deleted file mode 100644
index 754b40efabd8..000000000000
--- a/dev-python/PyContracts/files/PyContracts-1.8.14-fix-py3.10.patch
+++ /dev/null
@@ -1,150 +0,0 @@
-From d23ee2902e9e9aeffec86cbdb7a392d71be70861 Mon Sep 17 00:00:00 2001
-From: slorg1 <slorg1@gmail.com>
-Date: Tue, 16 Apr 2019 14:13:52 -0400
-Subject: [PATCH] + upgrade to use collections.abc as needed for python 3.6+
-
---- a/src/contracts/library/map.py
-+++ b/src/contracts/library/map.py
-@@ -1,7 +1,11 @@
- from ..interface import Contract, ContractNotRespected
- from ..syntax import (W, contract_expression, O, S, add_contract, add_keyword,
- Keyword)
--import collections
-+
-+try:
-+ import collections.abc as collectionsAbc # python 3.6+
-+except ImportError:
-+ import collections as collectionsAbc
-
-
- class Map(Contract):
-@@ -13,7 +17,7 @@ def __init__(self, length=None, key_c=None, value_c=None, where=None):
- self.value_c = value_c
-
- def check_contract(self, context, value, silent):
-- if not isinstance(value, collections.Mapping):
-+ if not isinstance(value, collectionsAbc.Mapping):
- error = 'Expected a Mapping, got %r.' % value.__class__.__name__
- raise ContractNotRespected(contract=self, error=error,
- value=value, context=context)
---- a/src/contracts/library/miscellaneous_aliases.py
-+++ b/src/contracts/library/miscellaneous_aliases.py
-@@ -1,12 +1,16 @@
--import collections
--
-+try:
-+ import collections.abc as collectionsAbc # python 3.6+
-+except ImportError:
-+ import collections as collectionsAbc
-
-
- def ist(C):
-+
- def f(x):
- f.__name__ = 'isinstance_of_%s' % C.__name__
- if not isinstance(x, C):
- raise ValueError('Value is not an instance of %s.' % C.__name__)
-+
- return f
-
-
-@@ -14,33 +18,32 @@ def m_new_contract(name, f):
- from contracts.library.extensions import CheckCallable
- from contracts.library.extensions import Extension
- Extension.registrar[name] = CheckCallable(f)
--
-
--m_new_contract('Container', ist(collections.Container))
--# todo: Iterable(x)
--m_new_contract('Iterable', ist(collections.Iterable))
--
--m_new_contract('Hashable', ist(collections.Hashable))
-
-+m_new_contract('Container', ist(collectionsAbc.Container))
-+# todo: Iterable(x)
-+m_new_contract('Iterable', ist(collectionsAbc.Iterable))
-
-+m_new_contract('Hashable', ist(collectionsAbc.Hashable))
-
--m_new_contract('Iterator', ist(collections.Iterator))
--m_new_contract('Sized', ist(collections.Sized))
--m_new_contract('Callable', ist(collections.Callable))
--m_new_contract('Sequence', ist(collections.Sequence))
--m_new_contract('Set', ist(collections.Set))
--m_new_contract('MutableSequence', ist(collections.MutableSequence))
--m_new_contract('MutableSet', ist(collections.MutableSet))
--m_new_contract('Mapping', ist(collections.Mapping))
--m_new_contract('MutableMapping', ist(collections.MutableMapping))
--#new_contract('MappingView', ist(collections.MappingView))
--#new_contract('ItemsView', ist(collections.ItemsView))
--#new_contract('ValuesView', ist(collections.ValuesView))
-+m_new_contract('Iterator', ist(collectionsAbc.Iterator))
-+m_new_contract('Sized', ist(collectionsAbc.Sized))
-+m_new_contract('Callable', ist(collectionsAbc.Callable))
-+m_new_contract('Sequence', ist(collectionsAbc.Sequence))
-+m_new_contract('Set', ist(collectionsAbc.Set))
-+m_new_contract('MutableSequence', ist(collectionsAbc.MutableSequence))
-+m_new_contract('MutableSet', ist(collectionsAbc.MutableSet))
-+m_new_contract('Mapping', ist(collectionsAbc.Mapping))
-+m_new_contract('MutableMapping', ist(collectionsAbc.MutableMapping))
-+# new_contract('MappingView', ist(collections.MappingView))
-+# new_contract('ItemsView', ist(collections.ItemsView))
-+# new_contract('ValuesView', ist(collections.ValuesView))
-
-
- # Not a lambda to have better messages
--def is_None(x):
-+def is_None(x):
- return x is None
-
-+
- m_new_contract('None', is_None)
- m_new_contract('NoneType', is_None)
---- a/src/contracts/library/seq.py
-+++ b/src/contracts/library/seq.py
-@@ -1,7 +1,12 @@
- from ..interface import Contract, ContractNotRespected
- from ..syntax import (add_contract, W, contract_expression, O, S, add_keyword,
- Keyword)
--import collections
-+
-+try:
-+ import collections.abc as collectionsAbc # python 3.6+
-+except ImportError:
-+ import collections as collectionsAbc
-+
- from past.builtins import xrange
-
- try:
-@@ -38,7 +43,7 @@ def check_contract(self, context, value, silent):
-
- return
-
-- if not isinstance(value, collections.Sequence):
-+ if not isinstance(value, collectionsAbc.Sequence):
- error = 'Expected a Sequence, got %r.' % value.__class__.__name__
- raise ContractNotRespected(self, error, value, context)
-
---- a/src/contracts/library/sets.py
-+++ b/src/contracts/library/sets.py
-@@ -1,7 +1,10 @@
- from ..interface import Contract, ContractNotRespected, describe_type
- from ..syntax import (Keyword, O, S, W, add_contract, add_keyword,
- contract_expression)
--import collections
-+try:
-+ import collections.abc as collectionsAbc # python 3.6+
-+except ImportError:
-+ import collections as collectionsAbc
-
-
- class ASet(Contract):
-@@ -13,7 +16,7 @@ def __init__(self, length_contract=None,
- self.elements_contract = elements_contract
-
- def check_contract(self, context, value, silent):
-- if not isinstance(value, collections.Set):
-+ if not isinstance(value, collectionsAbc.Set):
- error = 'Expected a set, got %r.' % describe_type(value)
- raise ContractNotRespected(self, error, value, context)
-
diff --git a/dev-python/PyContracts/metadata.xml b/dev-python/PyContracts/metadata.xml
deleted file mode 100644
index ab1d67f3e345..000000000000
--- a/dev-python/PyContracts/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">PyContracts</remote-id>
- <remote-id type="github">AndreaCensi/contracts</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 11e6d08819a6..ebbada3464c5 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -796,7 +796,6 @@ dev-python/imread
dev-python/influxdb
dev-python/nose-random
dev-python/pilkit
-dev-python/PyContracts
# Georgy Yakovlev <gyakovlev@gentoo.org> (2022-12-19)
# This version currently is not compatible with kernel build (yet)