summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-09-03 10:23:57 +0200
committerHanno Böck <hanno@gentoo.org>2020-09-03 10:24:34 +0200
commit19b88534226208742ab9b0b30db7ee96359166f8 (patch)
tree06ac6a2abec943cb864d57398f26772b1fc505a4
parentnet-analyzer/tcptraceroute: Update SRC_URI/EAPI (diff)
downloadgentoo-19b88534.tar.gz
gentoo-19b88534.tar.bz2
gentoo-19b88534.zip
dev-python/precis-i18n: Version bump.
Support Python 3.9. Bump EAPI to 7. Disable test that requires additional files from upstream. Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.5, Repoman-3.0.1
-rw-r--r--dev-python/precis-i18n/Manifest1
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.0.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/Manifest b/dev-python/precis-i18n/Manifest
index e568bbcd341c..fd602620d6c8 100644
--- a/dev-python/precis-i18n/Manifest
+++ b/dev-python/precis-i18n/Manifest
@@ -1 +1,2 @@
DIST precis_i18n-1.0.1.tar.gz 63941 BLAKE2B ee429304f41fd225b306d6df342e1ab62a9dcc3daa40ae08c88a02809230d7e356090c3414136799b176b74debfd901863cb673b577b336784411ca5baf3e92c SHA512 d8aaf99bbf3bde148f173ac8ffa5cab5051ec873d53e19336171dcd29f995e706746e5969d37aef05b6c9db064ca5e7b3944ae049b0a41e605e71a854248251b
+DIST precis_i18n-1.0.2.tar.gz 65375 BLAKE2B 0ba2a23838306502448c4bc4bba5fec5228e4b819e7223cb5319ca3428cd558b5fdbd389327af7a8e718a5b8369b3d13de0f739456df9bae026acbbaba62e8dc SHA512 bef972f44e068954297429a22452d08c0e3fca983eb38dd22e3f90b3265bba1096343d34f7c9a226b24f92a823fdabf09af8eafba6bfbfdc8ddda8f0f4a28bdf
diff --git a/dev-python/precis-i18n/precis-i18n-1.0.2.ebuild b/dev-python/precis-i18n/precis-i18n-1.0.2.ebuild
new file mode 100644
index 000000000000..9d8dd6bebc58
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="https://pypi.python.org/pypi/precis-i18n"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ # requires additional files not in tarball
+ rm test/test_derived_props_files.py
+ esetup.py test
+}