summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-05-11 10:22:00 -0700
committerJohn Helmert III <ajak@gentoo.org>2024-05-11 10:23:15 -0700
commit19c561070428e697131333a21ec4d304716aff2a (patch)
treea47b64de813b2e535b8309443fe919ed096dc164
parentsys-apps/util-linux: wire up uuidd properly (diff)
downloadgentoo-19c561070428e697131333a21ec4d304716aff2a.tar.gz
gentoo-19c561070428e697131333a21ec4d304716aff2a.tar.bz2
gentoo-19c561070428e697131333a21ec4d304716aff2a.zip
app-antivirus/lkrg: add 0.9.8
This release includes the new remote logging functionality. Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--app-antivirus/lkrg/Manifest2
-rw-r--r--app-antivirus/lkrg/lkrg-0.9.8.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-antivirus/lkrg/Manifest b/app-antivirus/lkrg/Manifest
index f9d6d62642da..92b1f312c0d5 100644
--- a/app-antivirus/lkrg/Manifest
+++ b/app-antivirus/lkrg/Manifest
@@ -2,3 +2,5 @@ DIST lkrg-0.9.6.tar.gz 129563 BLAKE2B d4a39a080312d8cb04152e613b96e0ce882ea9ba50
DIST lkrg-0.9.6.tar.gz.sign 801 BLAKE2B 2ed63da40ff75c7faee198e5de73ee7be5903c00a3b1cc2f6acda53274bcf8665183cefbf36749a30b0fd78c38ac8dc1fceeb5f37772e3d335ab22c133fdfa91 SHA512 3e9c3df84991a3f4bd2e71069c1fe76021cd9289b82a1dfaaf9a26fdd9ff94840a728b90235db3f185dc143402a3770a247bf8c70d098f170921ec811d9e5299
DIST lkrg-0.9.7.tar.gz 130913 BLAKE2B b6cda651e3c098f17148457be4e056315bfe8d5bb52a8051e9eff422f8deadb7d1e72420d99fa29704fc0216eafe0153b8a6f0c945e55ac5ee71a17043303f2f SHA512 bf1af6d1a4d6811a6e7a17473260c93632e2c0a0b92a2a2ea4a8c2a75a1aaa0811b5bcdb399d9bff8444d5af3b8f4d8394b9b862cd9607fa57a614472553e99c
DIST lkrg-0.9.7.tar.gz.sign 801 BLAKE2B ecb6f4521d0badd6b289bee0e68f6cff5d1dad3be74a8f7b32c828322fa12550d93291eeedff6e848e6db8805be7717cecc6d75cf4404481067f57200123f34e SHA512 66859311a9320b150e4783e389d2e0df32e04fc35ce3a2a4ac6a488215300677fdd63928e9a877a5fdaf44800cb403cc3ce6de8423adaa15fa3b9fc92b7537a5
+DIST lkrg-0.9.8.tar.gz 160156 BLAKE2B 6d07527b5c5b2bddd480a49090a4e4d448e37398c24aeda6bb4d21994f5fe6c2787538cb20d57ac57d38668c2b23b58a3502c96be2e65641fbee596f0d0ec2ca SHA512 86d08f0c0168244ea48fb510e20356f24d8134c96b53b454dc22e7a67fe513b6b57ef946a28288f917f4deca59bcc073401ee2e71d46dad4e634a12c60fe5371
+DIST lkrg-0.9.8.tar.gz.sign 801 BLAKE2B 7c205f33954a18aa7a405533f5541a0f7a0fbcc02502fcd05a7bead20b6f5028ec8c582fc539904a91f6c5faae46ac2fb4633f5be93e6a5535ea2cfd28918146 SHA512 577c183d4f7912351f86cf121494a690ce0f40b6cf16c64b9e28dbd5fb127f7461d9602619b53e3117cb820689e2b09f020ecdfc54a799ba8bbd1bc082024c5c
diff --git a/app-antivirus/lkrg/lkrg-0.9.8.ebuild b/app-antivirus/lkrg/lkrg-0.9.8.ebuild
new file mode 100644
index 000000000000..c26305babfb6
--- /dev/null
+++ b/app-antivirus/lkrg/lkrg-0.9.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1 systemd verify-sig
+
+DESCRIPTION="Linux Kernel Runtime Guard"
+HOMEPAGE="https://lkrg.org"
+SRC_URI="https://lkrg.org/download/${P}.tar.gz
+ verify-sig? ( https://lkrg.org/download/${P}.tar.gz.sign )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-openwall )"
+
+# MODULE_NAMES="lkrg(misc:${S}:${S})"
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/openwall.asc"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.4-gentoo-paths.patch" )
+
+pkg_setup() {
+ CONFIG_CHECK="HAVE_KRETPROBES KALLSYMS_ALL KPROBES JUMP_LABEL"
+ CONFIG_CHECK+=" MODULE_UNLOAD !PREEMPT_RT ~STACKTRACE"
+ linux-mod-r1_pkg_setup
+}
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.sign}
+ fi
+
+ default
+}
+
+src_compile() {
+ local modlist=( lkrg )
+ local modargs=(
+ P_KVER="${KV_FULL}"
+ P_KERNEL="${KERNEL_DIR}"
+ )
+ linux-mod-r1_src_compile
+
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" -C logger
+}
+
+src_install() {
+ # logger target not included by all
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${ED}" -C logger install
+
+ linux-mod-r1_src_install
+
+ systemd_dounit scripts/bootup/systemd/lkrg.service
+ newinitd scripts/bootup/openrc/lkrg lkrg.initd
+
+ insinto /lib/sysctl.d
+ newins scripts/bootup/lkrg.conf 01-lkrg.conf
+}