summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-29 11:42:49 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-29 12:32:05 +0100
commit19ccf51b5c79a78516470d81b4232ae7f96a4433 (patch)
tree3fba119affa048eaa575719a038901072b50fef5
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.212,4.9.212} - rem... (diff)
downloadgentoo-19ccf51b5c79a78516470d81b4232ae7f96a4433.tar.gz
gentoo-19ccf51b5c79a78516470d81b4232ae7f96a4433.tar.bz2
gentoo-19ccf51b5c79a78516470d81b4232ae7f96a4433.zip
dev-python/pyparted: Set CFLAGS=-fcommon
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=706904 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--dev-python/pyparted/pyparted-3.11.3.ebuild7
-rw-r--r--dev-python/pyparted/pyparted-999999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/dev-python/pyparted/pyparted-3.11.3.ebuild b/dev-python/pyparted/pyparted-3.11.3.ebuild
index 53553209b627..a058461368ad 100644
--- a/dev-python/pyparted/pyparted-3.11.3.ebuild
+++ b/dev-python/pyparted/pyparted-3.11.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_6} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="Python bindings for sys-block/parted"
HOMEPAGE="https://github.com/rhinstaller/pyparted/"
@@ -22,3 +22,8 @@ DEPEND="
virtual/pkgconfig
"
RESTRICT="test"
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}
diff --git a/dev-python/pyparted/pyparted-999999.ebuild b/dev-python/pyparted/pyparted-999999.ebuild
index c31f80411993..b34350ec1632 100644
--- a/dev-python/pyparted/pyparted-999999.ebuild
+++ b/dev-python/pyparted/pyparted-999999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_6} )
-inherit distutils-r1 git-r3
+inherit distutils-r1 flag-o-matic git-r3
DESCRIPTION="Python bindings for sys-block/parted"
HOMEPAGE="https://github.com/rhinstaller/pyparted/"
@@ -22,3 +22,8 @@ DEPEND="
virtual/pkgconfig
"
RESTRICT="test"
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}