summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-09 15:58:45 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-09 15:59:59 -0500
commit19ce64a45e05e65981c3b73b8bbf30f2ab1243eb (patch)
treec3a8b15437ca6832cce0959b9c1e59339f549b35
parentdev-libs/libzip: 1.5.1 version bump for testing (diff)
downloadgentoo-19ce64a4.tar.gz
gentoo-19ce64a4.tar.bz2
gentoo-19ce64a4.zip
net-analyzer/barnyard: Fix dependency and less USE checking
Closes: https://bugs.gentoo.org/665934 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--net-analyzer/barnyard/barnyard-0.2.0-r5.ebuild (renamed from net-analyzer/barnyard/barnyard-0.2.0-r4.ebuild)13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-analyzer/barnyard/barnyard-0.2.0-r4.ebuild b/net-analyzer/barnyard/barnyard-0.2.0-r5.ebuild
index 0868a7f8ffe2..5d369ae6705d 100644
--- a/net-analyzer/barnyard/barnyard-0.2.0-r4.ebuild
+++ b/net-analyzer/barnyard/barnyard-0.2.0-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ IUSE="mysql postgres sguil"
DEPEND="
net-libs/libpcap
- mysql? ( virtual/mysql )
+ mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:*[server] )
sguil? ( dev-lang/tcl:0 )"
RDEPEND="${DEPEND}
@@ -62,23 +62,20 @@ src_install () {
insinto /etc/snort
newins etc/barnyard.conf barnyard.conf
+ newconfd "${FILESDIR}"/barnyard.confd barnyard
+ newinitd "${FILESDIR}"/barnyard.rc6 barnyard
+
if use sguil ; then
sed -i -e "/config hostname:/s%snorthost%$(hostname)%" \
-e "/config interface/s:fxp0:eth0:" \
-e "s:output alert_fast:#output alert_fast:" \
-e "s:output log_dump:#output log_dump:" \
"${D}/etc/snort/barnyard.conf" || die "sed failed"
- fi
- newconfd "${FILESDIR}"/barnyard.confd barnyard
- if use sguil ; then
sed -i -e s:/var/log/snort:/var/lib/sguil/$(hostname): \
-e s:/var/run/barnyard.pid:/var/run/sguil/barnyard.pid: \
"${D}/etc/conf.d/barnyard" || die "sed failed"
- fi
- newinitd "${FILESDIR}"/barnyard.rc6 barnyard
- if use sguil ; then
sed -i -e "/start-stop-daemon --start/s:--exec:-c sguil --exec:" \
"${D}/etc/init.d/barnyard" || die "sed failed"
fi