summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-29 20:26:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-29 21:50:27 +0100
commit19e08760476c4fa68e79c16897542870b8f57c40 (patch)
treee78b8d15d30a736e365525cc2c91c4da71f9b1bd
parentdev-qt/qtvirtualkeyboard: 5.15.7 version bump (diff)
downloadgentoo-19e08760.tar.gz
gentoo-19e08760.tar.bz2
gentoo-19e08760.zip
dev-qt/qtwayland: 5.15.7 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtwayland/Manifest2
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.7.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 6533bb0349f1..aee700ada9fb 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,4 +1,6 @@
DIST qtwayland-5.15.5-gentoo-kde-2.tar.xz 35492 BLAKE2B 91334609155e4bd227d76e5972422b400ab4b6196389a1b6b4c271994287851bc3b624ae761ece1418037735784edf7740ed5337ef6972bf708c598c202b7e86 SHA512 2663b59c7647e8a7d5f64905be114fc1b248cd8e10c2eba6bddc25b74fbbc5216e8264f41f50b6368819664921e27dfe96d4c1556c0e56f8c3c2c0ed75a72080
+DIST qtwayland-5.15.7-gentoo-kde-1.tar.xz 42912 BLAKE2B e616cdb5aef13b6350658de2d6922109b7d827536afce98d67f7b1936c91de7521a6b4f8997926334cb77e1009fd4e27e4e0aef5c78cf9ba5a6c964797d2b1e1 SHA512 23be3f4e1612a557f1eb0c17cb158897b48910e336765b6c2e06ed892b67f368dfd4ba916373bbed9d3650a1e1f39b3768db39632b4763ad103515b32a86c0c2
DIST qtwayland-everywhere-opensource-src-5.15.5.tar.xz 567384 BLAKE2B 01ce4d546bda7bf332f8cc4f86a5e8bfb1be0ef60336ee3cae58266a25d51cf00fef3e6c4204f0179abc2ef748f88bd3a20f89f36da74d5d15c70ae7b4975186 SHA512 828dceb7bc54ce610a73f110f0aca332a90cf95df4a3bc971bd21c4e878366cb8d2248e609b73ce4d381579a143843c87a62f23dcc95767e522874e53a1b0327
+DIST qtwayland-everywhere-opensource-src-5.15.7.tar.xz 568024 BLAKE2B ed2031ea40c5618c2390865807ef33eae42a3231098f1959f0a7e9e3b8e8d70f4461647aaa11afeade0528aa4d14049b03cc566552a13dd4d1b5773ec3d16061 SHA512 a004a82ec2b4f132d597ae3c82b4079671ecdfeed09c455073e552197da2b9f921c85bef2b40be76e87e61d5ec1e7ab39ed232be26b27d9aed6e938c659965a3
DIST qtwayland-everywhere-src-6.3.2.tar.xz 836192 BLAKE2B 3cb7c72c37d4b69a798cd14cc9aca694ba6ed01330e71772653e841717dcdd1c6e0d77597066647430e5f52dd5cd48636e1a6a2dcaadc2ab86a52be803c90f92 SHA512 475ba168bacb2d35a5962b27542f43420e3baf42d2026699b272174076ee6a26f8c3663ba8e44508f2011c5b7a2e4b3086390264cdf621b393c79fe89265bd03
DIST qtwayland-everywhere-src-6.4.0.tar.xz 836088 BLAKE2B 3efc506e1a0bc63182397d483bf352e21d39c75a7360ee3fe839527451950875748aea5cf62207ffef38b845a12c2bbbefde918d14333d1b194a4ea39b82670f SHA512 745fcc84c936c3f2fa7382291b5013679f9e57d6c680f1d352b0a132ba7cbaaea1495211f8fc4f1af85a81c711794987e4e05284d3ac06c94e92e9b601dae924
diff --git a/dev-qt/qtwayland/qtwayland-5.15.7.ebuild b/dev-qt/qtwayland/qtwayland-5.15.7.ebuild
new file mode 100644
index 000000000000..50d24f6c6ecc
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+SLOT=5/${QT5_PV} # bug 815646
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=( "${FILESDIR}/${PN}-5.15.3-clang.patch" )
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}
+
+src_install() {
+ qt5-build_src_install
+ rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
+}