summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-16 21:31:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-16 21:31:43 +0200
commit19f009330e504bea2d103e9606be22b7a74a5717 (patch)
tree21e3292f47b70a5a42f9f928759e8d812a23c3a1
parentdev-python/asyncstdlib: Remove old (diff)
downloadgentoo-19f009330e504bea2d103e9606be22b7a74a5717.tar.gz
gentoo-19f009330e504bea2d103e9606be22b7a74a5717.tar.bz2
gentoo-19f009330e504bea2d103e9606be22b7a74a5717.zip
dev-python/asyncstdlib: Bump to 3.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/asyncstdlib/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index 55b1d215e3fa..32da1ce498bf 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1 +1,2 @@
DIST asyncstdlib-3.10.1.gh.tar.gz 45230 BLAKE2B daefacbb5712d200dc61d99cbf0deaa50925cfe2e8203f01a8083531d762b838d9603110a07ac1e1a00f17f1bb8ee7dc1a759d35949570fe134d21c4e48993ae SHA512 05e0e64f8262cf3ba6f8e784490597397e0d6a74f2052da80bb531df557dd3143c032589c429a407049ed04b093757c7a09674c66110befd6ab66b0edf883909
+DIST asyncstdlib-3.10.2.gh.tar.gz 45697 BLAKE2B 8f9bbee8d2a4e9f6a60a5088ef00940f22c2aec79557070d1b13d8d7256179bddaf1130ace0393e95e06e077824dd862e27a6c5d644ae52dab2d80989bb08027 SHA512 be5a8cbb521b8082ad9898907bce1a888443eafb24e2030f9dfbb2dff293646376ad44ebbc53d12e539ad70af935d833f2f114e383171388b9d724f274eb8421
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild
new file mode 100644
index 000000000000..10f7da0d6a0d
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/"
+SRC_URI="
+ https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest