summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-09-10 19:17:00 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-09-10 19:17:00 +0200
commit19fd8f929f791c589312f4c54634bfdd6cb41d5f (patch)
tree2fc487bebb08b7c6c0fed9c57a84a48f478988c8
parentdev-python/importlib_metadata: remove old (diff)
downloadgentoo-19fd8f92.tar.gz
gentoo-19fd8f92.tar.bz2
gentoo-19fd8f92.zip
media-libs/glm: respect EPREFIX
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--media-libs/glm/files/glm.pc.in (renamed from media-libs/glm/files/glm.pc)4
-rw-r--r--media-libs/glm/glm-0.9.9.6.ebuild10
2 files changed, 11 insertions, 3 deletions
diff --git a/media-libs/glm/files/glm.pc b/media-libs/glm/files/glm.pc.in
index e3bb5acc1aff..fc5c7bb7f90c 100644
--- a/media-libs/glm/files/glm.pc
+++ b/media-libs/glm/files/glm.pc.in
@@ -1,7 +1,7 @@
-prefix=/usr
+prefix=@CMAKE_INSTALL_PREFIX@
includedir=${prefix}/include
Name: GLM
Description: OpenGL Mathematics
-Version: 0.9.9
+Version: @GLM_VERSION@
Cflags: -I${includedir}
diff --git a/media-libs/glm/glm-0.9.9.6.ebuild b/media-libs/glm/glm-0.9.9.6.ebuild
index 8b84a358e2b7..89d9894cf71e 100644
--- a/media-libs/glm/glm-0.9.9.6.ebuild
+++ b/media-libs/glm/glm-0.9.9.6.ebuild
@@ -16,6 +16,14 @@ IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86
RDEPEND="virtual/opengl"
+src_prepare() {
+ cmake-utils_src_prepare
+ sed \
+ -e "s:@CMAKE_INSTALL_PREFIX@:${EPREFIX}/usr:" \
+ -e "s:@GLM_VERSION@:0.9.9:" \
+ "${FILESDIR}"/glm.pc.in > glm.pc || die
+}
+
src_configure() {
if use test; then
local mycmakeargs=(
@@ -34,5 +42,5 @@ src_install() {
doheader -r glm
dodoc -r *md doc/*
insinto /usr/$(get_libdir)/pkgconfig
- doins "${FILESDIR}"/glm.pc
+ doins glm.pc
}