summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-08 17:04:10 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-08 17:07:11 -0500
commit19ffdf6414b7215a89a25c6b13cbf9197c86451a (patch)
treef70ae1d9779a994e755b53e31533407bcf82d576
parentdev-python/safety: Remove old (diff)
downloadgentoo-19ffdf6414b7215a89a25c6b13cbf9197c86451a.tar.gz
gentoo-19ffdf6414b7215a89a25c6b13cbf9197c86451a.tar.bz2
gentoo-19ffdf6414b7215a89a25c6b13cbf9197c86451a.zip
app-misc/pax-utils: fix lddtree with pyelfutils-0.24
Bug: https://bugs.gentoo.org/599082 Package-Manager: portage-2.3.2_p5
-rw-r--r--app-misc/pax-utils/files/0001-lddtree.py-work-around-pyelftools-API-change.patch29
-rw-r--r--app-misc/pax-utils/pax-utils-1.1.6-r1.ebuild62
2 files changed, 91 insertions, 0 deletions
diff --git a/app-misc/pax-utils/files/0001-lddtree.py-work-around-pyelftools-API-change.patch b/app-misc/pax-utils/files/0001-lddtree.py-work-around-pyelftools-API-change.patch
new file mode 100644
index 000000000000..7a8b74ea1e03
--- /dev/null
+++ b/app-misc/pax-utils/files/0001-lddtree.py-work-around-pyelftools-API-change.patch
@@ -0,0 +1,29 @@
+From 6557b1512ebfda508345e032e09ed85789c16c98 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Tue, 8 Nov 2016 15:37:27 -0500
+Subject: [PATCH] lddtree.py: work around pyelftools API change
+
+Section names now get returned as strings rather than bytes. See
+108eaea9 upstream.
+
+Bug: https://bugs.gentoo.org/599082
+---
+ lddtree.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/lddtree.py b/lddtree.py
+index 3971a9a..8480248 100755
+--- a/lddtree.py
++++ b/lddtree.py
+@@ -72,6 +72,8 @@ def dbg(debug, *args, **kwargs):
+
+ def bstr(buf):
+ """Decode the byte string into a string"""
++ if isinstance(buf, str):
++ return buf
+ return buf.decode('utf-8')
+
+
+--
+2.10.2
+
diff --git a/app-misc/pax-utils/pax-utils-1.1.6-r1.ebuild b/app-misc/pax-utils/pax-utils-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..ceaf0bd47b97
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-1.1.6-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
+HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~solar/pax/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="caps debug python seccomp"
+
+RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
+ python? ( dev-python/pyelftools )
+ seccomp? ( sys-libs/libseccomp )"
+DEPEND="${RDEPEND}
+ caps? ( virtual/pkgconfig )
+ seccomp? ( virtual/pkgconfig )
+ app-arch/xz-utils"
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_DEBUG=$(usex debug) \
+ USE_PYTHON=$(usex python) \
+ USE_SECCOMP=$(usex seccomp) \
+ "$@"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/0001-lddtree.py-work-around-pyelftools-API-change.patch"
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux || \
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
+ else
+ tc-export CC PKG_CONFIG
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+}