summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2022-02-02 18:21:27 +0100
committerDaniel Pielmeier <billie@gentoo.org>2022-02-02 18:21:27 +0100
commit1a0138b87c71d2e2aa035d91cb3b11084923536f (patch)
treee09af8c847caefb6717789d2e740f5daeb5f993f
parentapp-admin/conky: Remove unused patches. (diff)
downloadgentoo-1a0138b87c71d2e2aa035d91cb3b11084923536f.tar.gz
gentoo-1a0138b87c71d2e2aa035d91cb3b11084923536f.tar.bz2
gentoo-1a0138b87c71d2e2aa035d91cb3b11084923536f.zip
media-sound/puddletag: Version bump.
Migrate to EAPI 8 and PEP517 build. Add python 3.10 support. Closes: https://bugs.gentoo.org/830713 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
-rw-r--r--media-sound/puddletag/Manifest1
-rw-r--r--media-sound/puddletag/puddletag-2.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/puddletag/Manifest b/media-sound/puddletag/Manifest
index e4833b3a44f9..64bf8ccf7f72 100644
--- a/media-sound/puddletag/Manifest
+++ b/media-sound/puddletag/Manifest
@@ -1 +1,2 @@
DIST puddletag-2.0.1.tar.gz 1227152 BLAKE2B 804e9ca9629a9d78114d6f4b6afbe9032cb414678ea6325679c21ac18867bafed8f1b16aae5fbea18995ecc800d35594c478a5164b377f3b4e5dd75148fd3246 SHA512 d84ba360a6cd8c3ddb6628e30276df58d059d9e8cbb2d1255320ca273436c69f05584059c2e768a15871d3f56dc08d7ac96fef9a9c7c077811bb9fdfde444610
+DIST puddletag-2.1.0.tar.gz 14628824 BLAKE2B 52ac6291682710eed81aa6176b1a53eb15aec8885a8421361d3da8850e8b1719d0d1c9b2f131ad826febc328244ec890cf6283f1945275458d75b1f923890dd2 SHA512 638c12be894d157d0456f336972f0064c4f4087d1c689f58b7b01f0e88cd773319b9c447e6f2b606f6e482b6d1e2328f5bc2aca556bab427b764d6525b8c2d5e
diff --git a/media-sound/puddletag/puddletag-2.1.0.ebuild b/media-sound/puddletag/puddletag-2.1.0.ebuild
new file mode 100644
index 000000000000..2e182ebcb057
--- /dev/null
+++ b/media-sound/puddletag/puddletag-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="Audio tag editor"
+HOMEPAGE="http://docs.puddletag.net/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acoustid quodlibet"
+
+DEPEND=""
+RDEPEND="
+ >=dev-python/configobj-5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.7[${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-5.15.2[${PYTHON_USEDEP},svg]
+ >=media-libs/mutagen-1.45.1[${PYTHON_USEDEP}]
+ acoustid? ( >=media-libs/chromaprint-1.4.3 )
+ quodlibet? ( >=media-sound/quodlibet-4.4.0[${PYTHON_USEDEP}] )
+ >=dev-python/sip-4.19.22:0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.2[${PYTHON_USEDEP}]
+"
+# docs
+# >=dev-python/wheel-0.35.1[${PYTHON_USEDEP}]
+# >=dev-python/markdown-3.1.1[${PYTHON_USEDEP}]
+# >=dev-python/sphinx-1.4.8[${PYTHON_USEDEP}]
+# >=dev-python/sphinx-bootstrap-theme-0.4.13[${PYTHON_USEDEP}]
+# >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
+
+DOCS=(changelog NEWS THANKS TODO)