summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-16 08:42:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-16 08:53:04 +0200
commit1a13d04af2dfa1a9ec529b51d75011e1783379ca (patch)
treebf1945d59b432f5b9d3d9ecb37cf0814518093b4
parentdev-python/hypothesis: Bump to 6.21.4 (diff)
downloadgentoo-1a13d04a.tar.gz
gentoo-1a13d04a.tar.bz2
gentoo-1a13d04a.zip
dev-python/signature_dispatch: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/signature_dispatch/Manifest1
-rw-r--r--dev-python/signature_dispatch/signature_dispatch-1.0.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/signature_dispatch/Manifest b/dev-python/signature_dispatch/Manifest
index 8cb04a2dcf84..e586ee04ef77 100644
--- a/dev-python/signature_dispatch/Manifest
+++ b/dev-python/signature_dispatch/Manifest
@@ -1,2 +1,3 @@
DIST signature_dispatch-0.1.0.tar.gz 8715 BLAKE2B c62f5d0b0b263e50215d588e83bab4b5ca6dff82f856ad6265a0bb2dd64e2a3a8dfd0b8989ec17424828575607bd4dccc5802ef072af271eddb88c2479e6b8e7 SHA512 687a1de540a61d274e93510d2c5a93c736a52587b0215aef91364e34ad8932b880361b53fb84e68f9c2083652fa97c759705b4d61bc74caeba73a4ff37b42785
DIST signature_dispatch-0.2.0.tar.gz 11422 BLAKE2B 3e3297ef34bb4f7352fe867edd2c804d627d5f8e854b1551c88dcdea2f83a6e2cde9c0f088d263e405f29ccd7114717c9348dc59d60ccd00a4ebb84db800d398 SHA512 e2fedfe3260be641c319364a8f79b2d1444179c824e409fb8304352cc9f73fc2cfb8fbdab6788c14d08e716d4655cda72bc15b406596d43520f959973fc612c5
+DIST signature_dispatch-1.0.0.tar.gz 15102 BLAKE2B d0fe384551136d23f815129849ec70c0d1bd8616dab571122b7407578f3cc0d614fc5c44f3de5d9541bed9e9e3a0887517fff1183fd6c782bde603d774fe09f1 SHA512 c13ac92f50a8bd7a9fcd0b231f74a14539fd9c0303fdb29860a93116512a20113708c3207c4b2d8f61a48a9632e8cd21f7ea3fcb49ae3a4b1c79eb6a71df4eab
diff --git a/dev-python/signature_dispatch/signature_dispatch-1.0.0.ebuild b/dev-python/signature_dispatch/signature_dispatch-1.0.0.ebuild
new file mode 100644
index 000000000000..73c2bc0b51b2
--- /dev/null
+++ b/dev-python/signature_dispatch/signature_dispatch-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Execute the first function that matches the given arguments"
+HOMEPAGE="
+ https://github.com/kalekundert/signature_dispatch/
+ https://pypi.org/project/signature-dispatch/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ dev-python/typeguard[${PYTHON_USEDEP}]"