summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-11 04:14:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-11 04:53:02 +0100
commit1a1d9c7ae49004d0f3d154b39d5fb40f284492a3 (patch)
treed5f2cf8c3347686a270ff7531b09d2496113712a
parentdev-python/hypothesis: Bump to 6.99.2 (diff)
downloadgentoo-1a1d9c7a.tar.gz
gentoo-1a1d9c7a.tar.bz2
gentoo-1a1d9c7a.zip
dev-python/redis: Bump to 5.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/redis/Manifest1
-rw-r--r--dev-python/redis/redis-5.0.3.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/redis/Manifest b/dev-python/redis/Manifest
index 2f6cb3801837..7372ff359d6c 100644
--- a/dev-python/redis/Manifest
+++ b/dev-python/redis/Manifest
@@ -1,2 +1,3 @@
DIST redis-py-5.0.1.gh.tar.gz 4769633 BLAKE2B 3b572ef41abfdb0cf0ba957c93a23aacbe931e50ebe11e50a62dffe6aaaf57926224f7a497727e1e233b443c6be053f786dadac64f16a5170748e6afd9604d01 SHA512 05c32d6961326ff39312f5513136e72be3a42819b0c4bf646f3bac14e66a8a87a191697a89c2cbc22a83398896e25adc5fbd34f12e67719f0a0af927bf423130
DIST redis-py-5.0.2.gh.tar.gz 4774000 BLAKE2B 60ca8e11c2896b2f36d09fa494afc3ea039a79eb46a4503d6c5561f16fd9e2779aecb314e79c87e083212b5a619c555615a037f83572bc0a8fe54b8d04e6530b SHA512 1f75f2959737fc4d9e83c1e88cebbaad8801ac1a6113a1275b6461c657136f6f561d8ac8c5a62ba3f1d7f5463c416aa6351f8150b983505e7b0a93e3e8b4b354
+DIST redis-py-5.0.3.gh.tar.gz 4774007 BLAKE2B f1b53319f76fd15af28941d643a333e7556f4701b46d218872a17200a867ba71c5fe72a092e00ac68ca811f41409a1e2eef05a235d2fcb6ba455cef225cd47c5 SHA512 be7158062e905ff3f61fc2b311b1288e53f494de1734dd5a58a34250754de635b9bf125900621b7b6ad8c67d8020b88ca3ae07af2626459acaf77db5f228222c
diff --git a/dev-python/redis/redis-5.0.3.ebuild b/dev-python/redis/redis-5.0.3.ebuild
new file mode 100644
index 000000000000..c3596deb755c
--- /dev/null
+++ b/dev-python/redis/redis-5.0.3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=redis-py-${PV}
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="
+ https://github.com/redis/redis-py/
+ https://pypi.org/project/redis/
+"
+SRC_URI="
+ https://github.com/redis/redis-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Flaky test
+ tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
+ # require extra redis modules that apparently aren't packaged
+ # on Gentoo
+ tests/{,test_asyncio/}test_bloom.py
+ tests/{,test_asyncio/}test_graph.py
+ tests/{,test_asyncio/}test_json.py
+ tests/{,test_asyncio/}test_timeseries.py
+ # apparently available only in "Redis Stack 7.2 RC3 or later"
+ tests/test_commands.py::TestRedisCommands::test_tfunction_load_delete
+ tests/test_commands.py::TestRedisCommands::test_tfunction_list
+ tests/test_commands.py::TestRedisCommands::test_tfcall
+ # TODO
+ tests/test_commands.py::TestRedisCommands::test_zrank_withscore
+ tests/test_commands.py::TestRedisCommands::test_zrevrank_withscore
+ tests/test_commands.py::TestRedisCommands::test_xinfo_consumers
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrank_withscore
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrevrank_withscore
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_xinfo_consumers
+ tests/test_asyncio/test_pubsub.py::TestPubSubAutoReconnect::test_reconnect_socket_error[pool-hiredis-listen]
+ )
+
+ # TODO: try to run more servers?
+ epytest -m "not redismod and not onlycluster and not replica and not ssl"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ if has_version ">=dev-db/redis-7"; then
+ local extra_conf="
+ enable-debug-command yes
+ enable-module-command yes
+ "
+ fi
+
+ # Spawn Redis itself for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ ${extra_conf}
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}