summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 23:58:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 23:58:48 +0200
commit1a201eee8c33ff83b1958b9c552bb30c424f509e (patch)
tree7195b3ee56bef25704d92c1f005fa278df3364c2
parentdev-python/astroid: Bump to 2.5.6 (diff)
downloadgentoo-1a201eee.tar.gz
gentoo-1a201eee.tar.bz2
gentoo-1a201eee.zip
dev-python/pylint: Bump to 2.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.8.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index cfc1e8a0c522..89204b78b63d 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -2,3 +2,4 @@ DIST pylint-2.7.1.tar.gz 708916 BLAKE2B 606637ff25daccba741ae5bcdecb6a2be50bc173
DIST pylint-2.7.2.tar.gz 709177 BLAKE2B 5e4daeb19b6b18d570f4d78b01cc5023d5d245840160fdbddb194ab7036118742ffe3075ee27c37bd7a700d11d9006dc9abaaba9cf9596ae1b63941f139da7ac SHA512 800b210fbe5665db390d5c885d103856dc474b4e43d2f752bdcfcea36121132c26eecdcb67620c4a90456823f11a33568de4d37d59eea692dcd1751d931420f7
DIST pylint-2.7.4.tar.gz 715507 BLAKE2B 141506c067195422d0b052924baf87c363c89e28b3279f5173d989ac9247163184840251bd05dfb7dbb765f7b2e921a851fde0323b6c4cc231bc58911c77f692 SHA512 2b7ec9ab3325209021cb0282a6dacabf7ddd1f5e4049157610015ac8c11413471defc9e0528f81e1a60c2b259260f1bde1d04286776b3f32f771968b9866d734
DIST pylint-2.8.0.tar.gz 734325 BLAKE2B 479c6f409a7da46d8416c4c06f76937b70ddbffab64d57a9107f9b04283fa985186684d3d146c5ca585a0e8e9369d28e4fbeb5f53262662d94edd862694dd4fa SHA512 d4f6b6c6046265beb0e17b8d375d2604a889bf9b6569d4dae9cdec3f92c8c76d440f6527c9d42f7197a73d4a65fab73f57e5ab99c98d40681119eb051b117211
+DIST pylint-2.8.1.tar.gz 734583 BLAKE2B eb28c54a952c87f9cf59d18956dbc632ff89f4d3a91423a84ee3d4468e5af5fe7fcf37288964af0f36884bc0c46d400e2414bbf114a4a06f75a5c8da50ba9030 SHA512 ec8710396f07cdec8a395748ffda403a1f3fbd00094a1ad32e976c52be946c08b9e32521205dc165a0284467c68d9f467be40d141907bcd148b94e285eeca606
diff --git a/dev-python/pylint/pylint-2.8.1.ebuild b/dev-python/pylint/pylint-2.8.1.ebuild
new file mode 100644
index 000000000000..4f033ab1f2c7
--- /dev/null
+++ b/dev-python/pylint/pylint-2.8.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint/"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/${P}.tar.gz"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/astroid-2.7[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.5.6[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ # Fails when graphviz is installed (?!)
+ tests/test_import_graph.py::test_missing_graphviz
+ # TODO
+ 'tests/lint/unittest_expand_modules.py::test_expand_modules[files_or_modules1-expected1]'
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests ${skipped_tests[@]/#/--deselect }
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}