summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-03-23 14:40:59 -0500
committerBen Kohler <bkohler@gentoo.org>2021-03-23 14:41:14 -0500
commit1a21a9af3690e64251136ee17bd8d94821af6ea9 (patch)
treebaaf4186e3b457aaf9ec2f8e2412f01e1d746039
parentapp-emulation/docker-compose: 1.28.6 (diff)
downloadgentoo-1a21a9af3690e64251136ee17bd8d94821af6ea9.tar.gz
gentoo-1a21a9af3690e64251136ee17bd8d94821af6ea9.tar.bz2
gentoo-1a21a9af3690e64251136ee17bd8d94821af6ea9.zip
sys-apps/hwinfo: bump to 21.72, take package
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--sys-apps/hwinfo/Manifest1
-rw-r--r--sys-apps/hwinfo/hwinfo-21.72.ebuild59
-rw-r--r--sys-apps/hwinfo/metadata.xml7
3 files changed, 65 insertions, 2 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index 7a06146360c6..7182a792023c 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -1,2 +1,3 @@
DIST hwinfo-21.23-1.2.src.rpm 844672 BLAKE2B 33cfd68c06081d76b33243474b9a72cc5994c749ff57b7fc4f36c88627707068fb86d4825bae66e4e08f730dc8849264f5f31f8717f28400b3d54302ac12b1eb SHA512 d25c955fa5620268a34a857916e0bdbbdb92f8e092735ac453e7bacc6476e00047c9ccef3a5275e5d50cc354bf9e3cffef57af519dc885d0afd3d161ab426629
DIST hwinfo-21.4-1.1.src.rpm 781525 BLAKE2B 83c6d0b3d15a7b4354223eef8b976643ec6520842007ce6fb06534360a8994d4aac0975eba059275910f59391e7069b0166b69301006ea78ca4b74c6aefbde7c SHA512 bccac7749751924e1e1a8005e6fd783da7114926b6d9b9a1247b3b26dd680848eb2b85b368c312d08b444c8d7b75036d249daf33afc5b7efbbcc09bfbad4b340
+DIST hwinfo-21.72-1.3.src.rpm 926285 BLAKE2B b8a38b2f04649e268a6d6fbebabd724a0c678e81ea9c09c3453ababa26e91ba5fe55c7feccf157ab81ab676e6610ba1700ef1691bdd06fbcbc1cdd86806282d2 SHA512 4e51ee4f8e03eee82317557aa39b5018cc2370b33bfdb280ecb8716687d951f8c34fa7598a1e0eff03025991eee654af488e3343d93167e4cf16380d047c2de3
diff --git a/sys-apps/hwinfo/hwinfo-21.72.ebuild b/sys-apps/hwinfo/hwinfo-21.72.ebuild
new file mode 100644
index 000000000000..0ba8bd099676
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-21.72.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib rpm toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://www.opensuse.org/"
+SRC_URI="http://download.opensuse.org/tumbleweed/repo/src-oss/src/${P}-1.3.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+ # Workaround from Arch, for using raw tarballs from git
+ echo 'touch changelog' > git2log
+ default
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc changelog README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}
diff --git a/sys-apps/hwinfo/metadata.xml b/sys-apps/hwinfo/metadata.xml
index 483ee9fe5899..7864c9786d4b 100644
--- a/sys-apps/hwinfo/metadata.xml
+++ b/sys-apps/hwinfo/metadata.xml
@@ -2,7 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>robbat2@gentoo.org</email>
- <name>Robin H. Johnson</name>
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">openSUSE/hwinfo</remote-id>
+ </upstream>
</pkgmetadata>