summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:57:51 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:11 +0100
commit1a322ececaba226b88e9b6d80adeb1a96d8bc94d (patch)
tree308a7e2162793ee3d9490a9833d6d50f26eedf1a
parentnet-misc/openvswitch: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-1a322ececaba226b88e9b6d80adeb1a96d8bc94d.tar.gz
gentoo-1a322ececaba226b88e9b6d80adeb1a96d8bc94d.tar.bz2
gentoo-1a322ececaba226b88e9b6d80adeb1a96d8bc94d.zip
net-misc/stunnel: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/stunnel/stunnel-5.58.ebuild2
-rw-r--r--net-misc/stunnel/stunnel-5.59.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/net-misc/stunnel/stunnel-5.58.ebuild b/net-misc/stunnel/stunnel-5.58.ebuild
index 611d402d15cf..256081a6b48b 100644
--- a/net-misc/stunnel/stunnel-5.58.ebuild
+++ b/net-misc/stunnel/stunnel-5.58.ebuild
@@ -92,6 +92,8 @@ pkg_postinst() {
chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
fi
+ tmpfiles_process stunnel.conf
+
einfo "If you want to run multiple instances of stunnel, create a new config"
einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
einfo "\'pid= \' with a unique filename. For openrc make a symlink from the"
diff --git a/net-misc/stunnel/stunnel-5.59.ebuild b/net-misc/stunnel/stunnel-5.59.ebuild
index 40631323d410..7f0616ce3608 100644
--- a/net-misc/stunnel/stunnel-5.59.ebuild
+++ b/net-misc/stunnel/stunnel-5.59.ebuild
@@ -93,6 +93,8 @@ pkg_postinst() {
chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
fi
+ tmpfiles_process stunnel.conf
+
einfo "If you want to run multiple instances of stunnel, create a new config"
einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
einfo "\'pid= \' with a unique filename. For openrc make a symlink from the"