summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:08 +0200
commit1a528731ff977d5f9f971094937f04d4c517ae02 (patch)
treeebd243a27c1798259615e3f0e7297349880e4a77
parentdev-python/pymountboot: Remove redundant versions (diff)
downloadgentoo-1a528731ff977d5f9f971094937f04d4c517ae02.tar.gz
gentoo-1a528731ff977d5f9f971094937f04d4c517ae02.tar.bz2
gentoo-1a528731ff977d5f9f971094937f04d4c517ae02.zip
dev-python/pyopencl: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2019.1.2.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 8694719c91a2..f76541884d8c 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,2 +1 @@
-DIST pyopencl-2019.1.2.tar.gz 343805 BLAKE2B 027b231231532403a5e18249bd438e1a5a67805a685e46fd9506f7286957b14068540f93a3733149aeba2a720f6c71e91db74351916ca974739374a05f2d2c74 SHA512 b2850622253f480cafacadbb9d13afea801af9d4dd52679f132fc0e5f1d4c2f4d3bdf83c9ed64c14c19ead75e6d36afa8b57ff52bbea135fc02291b1fe7b8636
DIST pyopencl-2020.2.tar.gz 351600 BLAKE2B 47a733d7a552f5d1f69a1a9710c3262d50c26651ed9f46146829babe28962e236e2c1b9ba3d3d14207f28bdc562323a94ab4c51dbf5fcf1a0b12282b3c6aff50 SHA512 233bbf2e99507d3a832222cc8149bf7ac17332a550e4867f843fcc2b31104d961a3f0d972b0a1878d4716b2da4548f1390560141cd09cb1ba13300c541b058b9
diff --git a/dev-python/pyopencl/pyopencl-2019.1.2.ebuild b/dev-python/pyopencl/pyopencl-2019.1.2.ebuild
deleted file mode 100644
index 2f72469ccad5..000000000000
--- a/dev-python/pyopencl/pyopencl-2019.1.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples opengl"
-
-RDEPEND="
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pytools-2017.5[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=virtual/opencl-2"
-DEPEND="${RDEPEND}"
-
-# The test suite fails if there are no OpenCL platforms available, and
-# even if there is one (which requires the presence of both an OpenCL
-# runtime *and* hardware supported by it - simply emerging any runtime
-# is not enough) the vast majority of tests end up skipped because by
-# default the portage user hasn't got sufficient privileges to talk
-# to the GPU.
-RESTRICT="test"
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- --cl-pretend-version=1.2 \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}