summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-07-17 20:04:23 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-09-17 23:32:12 +0200
commit1a6012953990dab4f896145e9822255c29b966fd (patch)
treebb8ee448e1370419d4984eb36dc7ee2ff0790bc5
parentapp-crypt/kbfs: Updated dependencies (diff)
downloadgentoo-1a6012953990dab4f896145e9822255c29b966fd.tar.gz
gentoo-1a6012953990dab4f896145e9822255c29b966fd.tar.bz2
gentoo-1a6012953990dab4f896145e9822255c29b966fd.zip
app-text/libmwaw: Version bump to 0.3.8
Package-Manager: portage-2.2.28
-rw-r--r--app-text/libmwaw/Manifest1
-rw-r--r--app-text/libmwaw/libmwaw-0.3.8.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index cc6fde788b50..5709560d2ee1 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1,2 +1,3 @@
DIST libmwaw-0.3.6.tar.xz 1136836 SHA256 015f1c7ce4b023512e72897e36c7b2f74533d49fa65689e6480a8632ad09650c SHA512 fb653080b4d1a9c13f998d998dcdd0b790f69f70f91d6a426661bde49e32fb977d49c50893141e6901de0b9a832159dd989661d6889f267c0dbe0064e7f342d1 WHIRLPOOL ec8171be462ccb6d1b656fbf546eeccf38332ff27fed565c281454754470992ba9fc4dbed2772ad3c81a57f57c55c06dafdd9180547e698dd970389f49b1df8f
DIST libmwaw-0.3.7.tar.xz 1167156 SHA256 057611e871c279a28fcbede78dda11e500b9d5b341ab7064d6dce470f6fee8f9 SHA512 17f15f029633a22f8e7db7855b32dd5f4061e1eb3df865426bb736d2a5f3b7c0f631c22506aaed77e5fc4bce0e881c1f28f58a600c1155eac91d5897027b5499 WHIRLPOOL 8a9a05879e5c657be144685730e444290e3746949d77d7d3f1fe0700a32e86b786d93ae60ad4175c179b081263773f0a8121434f789b7413fbce5c7221b02111
+DIST libmwaw-0.3.8.tar.xz 1200052 SHA256 6afcbb250b6bed042149cd4dfb3ba7b4be796b11fe2322dfcdebd121199a3b05 SHA512 3e3684479460d22b83da225f8f1bc4de306f8e4a9e48c7ea128cba08f122b093c529f2e73b8f8ae1b235665d4f3c7de2fc461692e21f13364da678add707d01c WHIRLPOOL 77d9b1253191089da5c869e7bb160253672747cfd502350b28acde538e02b8418c0ee63899bf903b4c3c9f1561d145d0626c822f26467cb8ba7aa4de04287158
diff --git a/app-text/libmwaw/libmwaw-0.3.8.ebuild b/app-text/libmwaw/libmwaw-0.3.8.ebuild
new file mode 100644
index 000000000000..a8a3aae2772a
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="http://sourceforge.net/p/libmwaw/wiki/Home/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46:=
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-sharedptr=boost \
+ --enable-zip \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}