summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-22 16:10:27 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-22 22:58:35 -0400
commit1a6aae8681a88a123579506a5880f6f54f982483 (patch)
tree61e82b0f45b2f53dbda3fca24765b15f1335f5de
parentdev-util/spirv-llvm-translator: Look for spirv-headers in ESYSROOT (diff)
downloadgentoo-1a6aae86.tar.gz
gentoo-1a6aae86.tar.bz2
gentoo-1a6aae86.zip
dev-util/spirv-llvm-translator: Move clang to BDEPEND="test? ( ... )"
clang is only a test dependency. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild (renamed from dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0.ebuild)6
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0-r1.ebuild (renamed from dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0.ebuild)6
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
index cd3324c655c5..512723205247 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
@@ -23,7 +23,6 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-util/spirv-headers
- sys-devel/clang:${SLOT}
sys-devel/llvm:${SLOT}
"
@@ -31,7 +30,10 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- test? ( dev-python/lit )
+ test? (
+ dev-python/lit
+ sys-devel/clang:${SLOT}
+ )
"
src_prepare() {
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0-r1.ebuild
index 24731ea4c979..053b146fad72 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0-r1.ebuild
@@ -23,7 +23,6 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-util/spirv-headers
- sys-devel/clang:${SLOT}
sys-devel/llvm:${SLOT}
"
@@ -31,7 +30,10 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- test? ( dev-python/lit )
+ test? (
+ dev-python/lit
+ sys-devel/clang:${SLOT}
+ )
"
PATCHES=(