summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-05 11:15:20 +0000
committerSam James <sam@gentoo.org>2024-01-05 11:16:31 +0000
commit1a83ec4b3613f0b408b2b432717e0e88d6ca1bcf (patch)
tree63e06fc6fe136c28a43fdcd517a3391e83aa3fee
parentdev-util/cmake: move Emacs files to app-emacs/cmake-mode (diff)
downloadgentoo-1a83ec4b3613f0b408b2b432717e0e88d6ca1bcf.tar.gz
gentoo-1a83ec4b3613f0b408b2b432717e0e88d6ca1bcf.tar.bz2
gentoo-1a83ec4b3613f0b408b2b432717e0e88d6ca1bcf.zip
app-emacs/cmake-mode: new package split out from dev-util/cmake[emacs], add 3.28.1
Makes sense both to avoid circular deps with USE=emacs (if Emacs depends directly or indirectly on anything using CMake) but also because CMake takes a while to build. Suggested-by: Maciej Barć <xgqt@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emacs/cmake-mode/Manifest1
-rw-r--r--app-emacs/cmake-mode/cmake-mode-3.28.1.ebuild29
-rw-r--r--app-emacs/cmake-mode/files/50cmake-gentoo.el4
-rw-r--r--app-emacs/cmake-mode/metadata.xml14
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/cmake-mode/Manifest b/app-emacs/cmake-mode/Manifest
new file mode 100644
index 000000000000..5846714671d3
--- /dev/null
+++ b/app-emacs/cmake-mode/Manifest
@@ -0,0 +1 @@
+DIST cmake-3.28.1.tar.gz 11065923 BLAKE2B 7c6d3876633024b8a22dd6aca078e4bd7649c18a810ada68378435e9cfc30878b89529dc69e6e2dcecd114c9686fe6ce937fa5587e47f00128504349cecb967b SHA512 62693c423dd46d252d046662ac34cf9c927b7ec23c213c6b5cd1683636b8bbb5326698af1e7f851f3c01fe3f14dd769b9a8bd405f8f9e73e6d8defae7517cbcb
diff --git a/app-emacs/cmake-mode/cmake-mode-3.28.1.ebuild b/app-emacs/cmake-mode/cmake-mode-3.28.1.ebuild
new file mode 100644
index 000000000000..5cc983bc2a23
--- /dev/null
+++ b/app-emacs/cmake-mode/cmake-mode-3.28.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_P="${P/-mode}"
+MY_P="${MY_P/_/-}"
+
+DESCRIPTION="GNU Emacs mode for handling CMake build files"
+HOMEPAGE="https://cmake.org/"
+SRC_URI="https://cmake.org/files/v$(ver_cut 1-2)/${MY_P}.tar.gz"
+S="${WORKDIR}"/${P/-mode}/Auxiliary
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="!dev-util/cmake[emacs(-)]"
+
+DOCS=()
+
+SITEFILE="50${PN/-mode}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
diff --git a/app-emacs/cmake-mode/files/50cmake-gentoo.el b/app-emacs/cmake-mode/files/50cmake-gentoo.el
new file mode 100644
index 000000000000..e4a1a6d47cbc
--- /dev/null
+++ b/app-emacs/cmake-mode/files/50cmake-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'cmake-mode "cmake-mode" "Major mode for editing CMake files." t)
+(add-to-list 'auto-mode-alist '("CMakeLists\\.txt\\'" . cmake-mode))
+(add-to-list 'auto-mode-alist '("\\.cmake\\'" . cmake-mode))
diff --git a/app-emacs/cmake-mode/metadata.xml b/app-emacs/cmake-mode/metadata.xml
new file mode 100644
index 000000000000..a2714d42cd15
--- /dev/null
+++ b/app-emacs/cmake-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>