summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-02 05:03:01 +0000
committerSam James <sam@gentoo.org>2021-01-02 05:03:56 +0000
commit1a9e4893d0449db923e9ec37a686c419c24a84e2 (patch)
treebcdcdcdd543549f992e8315a44d423ea6a818eba
parentnet-analyzer/cacti: add github remote-id (diff)
downloadgentoo-1a9e4893d0449db923e9ec37a686c419c24a84e2.tar.gz
gentoo-1a9e4893d0449db923e9ec37a686c419c24a84e2.tar.bz2
gentoo-1a9e4893d0449db923e9ec37a686c419c24a84e2.zip
net-analyzer/cacti-spine: bump to 1.2.16
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.16.ebuild49
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-99999.ebuild14
3 files changed, 56 insertions, 8 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index ce570009bfd0..9f8ae426ed58 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,2 +1,3 @@
DIST cacti-spine-1.2.13.tar.gz 107543 BLAKE2B e0de75688334d27604a76c00a09ac53587a1e57f45df925e30a1a88a5e0449df803dfad901328c65b55484bc9022bf81d53880f17d4bd4efd9214315f01f7e92 SHA512 86d44195847c7b3acb1f6aed2bd6a57f562645b20724560d6b4bf7962707be4eb2f5326731453937b64420b5d51b714aecbd8dbea58d95f29ef4341515df8b00
DIST cacti-spine-1.2.14.tar.gz 107577 BLAKE2B 5865d93ffefeeafac1d2245000467deac79f8008e81b66de310bf08e7aa31f17299a82fc107ad49c3741bc2f183bdbc9554f814bf9e3e4b1dc85e267e4f16112 SHA512 44dec1077b419dfc987a1d423f2df597bf2026ca7f39aaafabfc7de9e6fdc616f505b86ace43bb2ad628f220cf8d8cf136a04f00c4fd23ab73da75068f804999
+DIST cacti-spine-1.2.16.tar.gz 108252 BLAKE2B ba0349cff7f4e82a5dc1d90c216cf7a4e0f939e28ab20d008b1725c948a85a00e2594f8997c8bbd69c305e3e58d944858c8439210956f45220b67229bc6df13d SHA512 0259084d70f9c8d20a8b19daf61e525228f99fba3eac4e2e5c9865114a5f1231b18389ca955fc4644c71c6c48cc45dda9b17e969a02c80552b84f98ad8945951
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.16.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.16.ebuild
new file mode 100644
index 000000000000..86a76185c475
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.16.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+BDEPEND="sys-apps/help2man"
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+RDEPEND="
+ ${DEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}
diff --git a/net-analyzer/cacti-spine/cacti-spine-99999.ebuild b/net-analyzer/cacti-spine/cacti-spine-99999.ebuild
index 34e6c184a65d..1367debdc14e 100644
--- a/net-analyzer/cacti-spine/cacti-spine-99999.ebuild
+++ b/net-analyzer/cacti-spine/cacti-spine-99999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools git-r3
MY_P=${PN}-${PV/_p/-}
@@ -15,27 +16,24 @@ SLOT="0"
KEYWORDS=""
IUSE="libressl"
-CDEPEND="
+BDEPEND="sys-apps/help2man"
+DEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-analyzer/net-snmp:=
dev-db/mysql-connector-c:0=
"
-DEPEND="
- ${CDEPEND}
- sys-apps/help2man
-"
RDEPEND="
- ${CDEPEND}
+ ${DEPEND}
>net-analyzer/cacti-0.8.8
"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
)
src_prepare() {
default
-
eautoreconf
}