summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-12 18:30:21 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-12 18:30:46 -0400
commit1ab11a031613047edd4c088cf2d76ff48dd6ca58 (patch)
tree05cf12e1636defdd140bdc3ef61c4bdeda2ce04a
parentdev-util/radare2: drop old (diff)
downloadgentoo-1ab11a031613047edd4c088cf2d76ff48dd6ca58.tar.gz
gentoo-1ab11a031613047edd4c088cf2d76ff48dd6ca58.tar.bz2
gentoo-1ab11a031613047edd4c088cf2d76ff48dd6ca58.zip
games-emulation/stella: version bump
Package-Manager: portage-2.2.26
-rw-r--r--games-emulation/stella/Manifest1
-rw-r--r--games-emulation/stella/stella-4.7.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index bb3500f2f21a..291269272ae9 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1 +1,2 @@
DIST stella-4.0-src.tar.gz 2283736 SHA256 bc3445109a090360070644f249b7b6c8f73b6044606d77d65303538785d426c9 SHA512 42df4429dfbfc268e7b7d1c538641b443703ba2af4ad4e66b9df05f2b7d62a860a1895f738d95a3a0b879052865137d31a22b8611f3b93ff9746649553c099fa WHIRLPOOL f0e1433a509724f0a5725aefbd1bb277729e985a173551051c2bf39eeb279f19053f14d6fa384f1a0104de9d0f9cd6f49ffe84347fcd59edb42189e681772a95
+DIST stella-4.7.2-src.tar.xz 1715332 SHA256 b2727a0e2d3b112d35dcb89b4bdc789e2c7f15e9d9c7054a69a2f67facd7416e SHA512 dcfaba9b554ab08c9ba79c8e95551bc688fae4ab0ab368df11c05f3dc7c9431d32068d5dd658ec4d1aa8cb826c7205fc4f301145a149d32369833409992455e2 WHIRLPOOL 5eb23541879b82083784054cc6783a55f7c70533a03747f7b5b5fec6632bb0b6062c9a530a6d5e98552749c8e22de8cbf08254407cdd3b6281a7f4aae74cb514
diff --git a/games-emulation/stella/stella-4.7.2.ebuild b/games-emulation/stella/stella-4.7.2.ebuild
new file mode 100644
index 000000000000..7d23b1fb3477
--- /dev/null
+++ b/games-emulation/stella/stella-4.7.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stella/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick"
+
+DEPEND="media-libs/libsdl2[joystick?,opengl,video]
+ media-libs/libpng:0
+ sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ local i
+
+ DOCS="Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt" \
+ default
+
+ for i in 16 22 24 32 48 64 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+ domenu src/unix/stella.desktop
+ dohtml -r docs/*
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}