summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-26 03:40:51 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-26 03:46:06 +0200
commit1abd8e4b908889deeecac3517c2aa1d940b80699 (patch)
tree8d342aad3b1cfe7f8dcf8a93159a77cf8baa1e96
parentdev-db/myodbc: bump to v8.0.21 (diff)
downloadgentoo-1abd8e4b908889deeecac3517c2aa1d940b80699.tar.gz
gentoo-1abd8e4b908889deeecac3517c2aa1d940b80699.tar.bz2
gentoo-1abd8e4b908889deeecac3517c2aa1d940b80699.zip
dev-python/mysql-connector-python: bump to v8.0.21
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-python/mysql-connector-python/Manifest1
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index f5a6ffea00f4..078755c5936a 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1 +1,2 @@
DIST mysql-connector-python-8.0.20.tar.gz 12058227 BLAKE2B ac16d0eb7ccc884e89bd493ce821b06223c7ea7a4c4ffce2ebc586c736524d826d92d3e3c7803c1f937c93a9f28df32205a04b3bd80474650e90bc267661879d SHA512 3b7298036f1b28eed98ca05ebc52619dbdf65393b4a01bf6eccea87d298da430ecfd19a3b327050ebc48b2c237698c7545c0196949d84cb79117f4d767d736aa
+DIST mysql-connector-python-8.0.21.tar.gz 12069002 BLAKE2B db4e7672f0daace08c88e52560db66629d5eb9d9903b76e616bed7ef4a21d80139a65ac24d47d16f9fa5e978f3acb262292c72933f0c348d9494cd51f96f1654 SHA512 d73efd99774450bbf729ddbb19b80d09b8db151715d12b76e40497bf1d9ff658e0ad1e22dc9a73dd5f6736f7c075f94808a2f28b1c975aaa380bbb92cf4e7184
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild
new file mode 100644
index 000000000000..b6c5eebd14bc
--- /dev/null
+++ b/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python client library for MariaDB/MySQL"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
+SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+
+BDEPEND=">=dev-libs/protobuf-3.6.1"
+
+RDEPEND="
+ >=dev-db/mysql-connector-c-8.0
+ >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+# tests/mysqld.py does not like MariaDB version strings.
+# See the regex MySQLServerBase._get_version.
+DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
+
+# Tests currently fail.
+# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
+RESTRICT="test"
+
+DOCS=( README.txt CHANGES.txt README.rst )
+
+python_test() {
+ "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
+}
+
+# Yeah, this is really broken, but the extension will only build this way during "install"
+python_install() {
+ distutils-r1_python_install \
+ --with-mysql-capi="${EPREFIX}/usr" \
+ --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
+ --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-protoc="${EPREFIX}/usr/bin/protoc"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples ; then
+ dodoc -r examples
+ fi
+}