summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-01 20:59:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-01 21:30:40 +0300
commit1ac1f5d5f5377c5c2c60282ac85ed7ec845060c6 (patch)
tree53837970413c5eb3a37ee9b4e51d6b7619e8a093
parentdev-python/pytest: add github upstream metadata (diff)
downloadgentoo-1ac1f5d5.tar.gz
gentoo-1ac1f5d5.tar.bz2
gentoo-1ac1f5d5.zip
dev-python/pytest-flake8: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild b/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
index 5c07f0c34d63..6398ac03bfb8 100644
--- a/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
+++ b/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="py.test plugin for flake8"
@@ -14,8 +14,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 x86"
-RDEPEND="
- >=dev-python/flake8-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.5[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/flake8-3.5.0[${PYTHON_USEDEP}]"
distutils_enable_tests pytest