summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-09-11 07:15:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-09-11 07:15:31 +0000
commit1aca2ebe8f657c6a8ca0d87a66458787ae8fd987 (patch)
tree662aab605049dc580ef992536442f3cc25ba1938
parentdev-python/flask: Remove old (diff)
downloadgentoo-1aca2ebe8f657c6a8ca0d87a66458787ae8fd987.tar.gz
gentoo-1aca2ebe8f657c6a8ca0d87a66458787ae8fd987.tar.bz2
gentoo-1aca2ebe8f657c6a8ca0d87a66458787ae8fd987.zip
dev-db/postgis: Bump to 3.3.1
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--dev-db/postgis/Manifest1
-rw-r--r--dev-db/postgis/postgis-3.3.1.ebuild140
2 files changed, 141 insertions, 0 deletions
diff --git a/dev-db/postgis/Manifest b/dev-db/postgis/Manifest
index 50076850456f..d409bad8a69f 100644
--- a/dev-db/postgis/Manifest
+++ b/dev-db/postgis/Manifest
@@ -8,3 +8,4 @@ DIST postgis-3.2.0.tar.gz 16884722 BLAKE2B 118ae754199521e46508b404275bfe323465e
DIST postgis-3.2.1.tar.gz 16883824 BLAKE2B 9c49ad518fb968dc4787bedf6480af29c3e70f986df8233ef034f117b8a8920ff6e39dab57813390b813a3d856476634b18e6ce324795839d019a11559155ff5 SHA512 e0ea3d2304e71c98dd045a8031946235d9c26a1310e1ffa556db10dfd18378957ee3d88608fba7ff482835d8c8b41d7f7bddaff1279ce0b50cd7634237465b31
DIST postgis-3.2.3.tar.gz 16882282 BLAKE2B 1f482f4411f3989bb7e389ae19b7c8e8d9f8b2c1689979d919d20feaa5c0dc46c009034fd06e89e2198e0f2234aaf2970f6f87303bde34dafbd78f818a880288 SHA512 f58b30af6d107578cb66de55bbeedc9ba503f85e5ead3f104e25a9d95a410e8c1a857936d805355a22185d5658e5908605fa9b317ed58497c29d752b70b4483e
DIST postgis-3.3.0.tar.gz 17718971 BLAKE2B f4fbd58ea4a815ea27d4611a8feb86346a695da7f443f16da330c780b0e0a36150d7f455c33ce0a5c6cda6931c8ed75f26eefe1d927aecddcf2d656fd6770194 SHA512 38da1c3a43eeeaf0eaa526db1036c0861c0cc3a5586b7d942d3d50296e85904aec80eb7f3689aa1ef854fbb979aafe8237cc4c0a71024b05f5cd7f5ea20722e3
+DIST postgis-3.3.1.tar.gz 17750909 BLAKE2B b24bbddae8ecad21525d3542cce409803b5e4f33e18d17d1e5b6cd04d99b64340720d9e60602af2cce6f6c9636c9943d6a14d5a2e34b0d5c32f6e3d87e6590f8 SHA512 1d4cfff6e34bc6f790f1ea209ba4d7b2a7633bdc0a1d57bb7c8ef9850b4f08c2926116d2fdfe97379c7431c0ec1559002166cebc0074041e9ae1fad03301bdd8
diff --git a/dev-db/postgis/postgis-3.3.1.ebuild b/dev-db/postgis/postgis-3.3.1.ebuild
new file mode 100644
index 000000000000..94b626598275
--- /dev/null
+++ b/dev-db/postgis/postgis-3.3.1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( {11..15} )
+POSTGRES_USEDEP="server"
+inherit autotools postgres-multi toolchain-funcs
+
+MY_P="${PN}-$(ver_rs 3 '')"
+
+if [[ ${PV} = *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.osgeo.org/gitea/postgis/postgis.git"
+else
+ PGIS="$(ver_cut 1-2)"
+ SRC_URI="https://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="https://postgis.net"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="address-standardizer doc gtk static-libs topology"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+RDEPEND="${POSTGRES_DEP}
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/protobuf-c:=
+ >=sci-libs/geos-3.9.0
+ >=sci-libs/proj-4.9.0:=
+ >=sci-libs/gdal-1.10.0:=
+ address-standardizer? ( dev-libs/libpcre )
+ gtk? ( x11-libs/gtk+:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/libxslt
+ virtual/imagemagick-tools[png]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.3-try-other-cpp-names.patch"
+)
+
+src_prepare() {
+ default
+
+ if [[ ${PV} = *9999* ]] ; then
+ source "${S}"/Version.config
+ PGIS="${POSTGIS_MAJOR_VERSION}.${POSTGIS_MINOR_VERSION}"
+ fi
+
+ # These modules are built using the same *FLAGS that were used to build
+ # dev-db/postgresql. The right thing to do is to ignore the current
+ # *FLAGS settings.
+ QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
+
+ # bug #775968
+ touch build-aux/ar-lib || die
+
+ local AT_M4DIR="macros"
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ export CPP=$(tc-getCPP)
+
+ local myeconfargs=(
+ $(use_with address-standardizer)
+ $(use_with gtk gui)
+ $(use_with topology)
+ )
+ postgres-multi_foreach econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C topology
+
+ if use doc ; then
+ postgres-multi_foreach emake comments
+ postgres-multi_foreach emake cheatsheets
+ postgres-multi_forbest emake -C doc html
+ fi
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+ postgres-multi_foreach emake -C topology DESTDIR="${D}" install
+ postgres-multi_forbest dobin ./utils/postgis_restore.pl
+
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+
+ if use doc ; then
+ postgres-multi_foreach emake DESTDIR="${D}" comments-install
+
+ docinto html
+ postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
+
+ docinto html/images
+ postgres-multi_forbest dodoc doc/html/images/*
+ fi
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
+
+pkg_postinst() {
+ ebegin "Refreshing PostgreSQL symlinks"
+ postgresql-config update
+ eend $?
+
+ local base_uri="https://postgis.net/docs/manual-"
+ if [[ ${PV} = *9999* ]] ; then
+ base_uri+="dev"
+ else
+ base_uri+="${PGIS}"
+ fi
+
+ elog "To finish installing PostGIS, follow the directions detailed at:"
+ elog "${base_uri}/postgis_installation.html#create_new_db_extensions"
+}